Hi Mateusz,

I tested your gzip.config and it worked for me (you have an extra  “[“ next to the “true” value for “flush" but that impacts only if the flush would be enabled or not).

There must be something different in your case…
You could run the traffic_server in debug mode with ‘./bin/traffic_server -T gzip’ and see the log messages from the gzip plugin.

Here is what worked for me (using your gzip.config) … It is not 100% the same but at least similar… 
it also uses ATS 5.3.2 which should not make a major difference (i don’t think there were any functional changes in the plugin).

curl -s -x localhost:80 http://gzip.example.com/test.crl -H "Accept-Encoding: gzip, deflate" -v  -o /dev/null -s
* About to connect() to proxy localhost port 80 (#0)
*   Trying 127.0.0.1... connected
* Connected to localhost (127.0.0.1) port 80 (#0)
> GET http://gzip.example.com/test.crl HTTP/1.1
> User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.19.1 Basic ECC zlib/1.2.3 libidn/1.18 libssh2/1.4.2
> Host: gzip.example.com
> Accept: */*
> Proxy-Connection: Keep-Alive
> Accept-Encoding: gzip, deflate
< HTTP/1.1 200 OK
< Server: ATS/5.3.2
< Date: Thu, 22 Oct 2015 17:22:50 GMT
< Content-type: application/json
< Content-Encoding: gzip
< Vary: Accept-Encoding
< Age: 0
< Transfer-Encoding: chunked
< Proxy-Connection: keep-alive
< Via: http/1.0 centos6 (ApacheTrafficServer/5.3.2)
{ [data not shown]
* Connection #0 to host localhost left intact
* Closing connection #0

Unrelated to the problem note: I was wondering if you really need “flush true” which will run deflate with Z_SYNC_FLUSH instead of Z_NO_FLUSH (reference http://zlib.net/manual.html#Basic), not sure, you may have a good reason for it.

HTH.

Cheers,
—Gancho




On Oct 22, 2015, at 6:34 AM, Mateusz Zajakala <zajakala@gmail.com> wrote:

Hi,

I'd appreciate any suggestion, I'm trying to use gzip plugin and it does not seem to work, my config is as follow:

plugin.config:
gzip.so /etc/trafficserver/gzip.config

/etc/trafficserver/gzip.config :
# Set some global options first
cache true
enabled true
remove-accept-encoding true
compressible-content-type application/json
flush true[

After that I restart ATS, see in logs:
 NOTE: loading plugin '/usr/lib64/trafficserver/plugins/gzip.so'

When I make a request to ATS from firefox:
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: pl,en-US;q=0.7,en;q=0.3
Accept-Encoding: gzip, deflate
Connection: keep-alive
Cache-Control: max-age=0
I get these headers in response:
HTTP/1.1 200 OK
Server: ATS/5.3.0
Access-Control-Allow-Origin: *
Expires: Thu, 22 Oct 2015 14:08:29 GMT
Cache-Control: max-age=3600
Content-Type: application/json;charset=UTF-8
Date: Thu, 22 Oct 2015 13:08:29 GMT
Age: 1075
Content-Length: 118
Connection: keep-alive

No gzip Content-Encoding.

What am I missing??