Is it only the problem of ts_lua plugin or other plugins have the same problem? e.g. you can try the regex_remap or header_rewrite plugin and see if you have the same problem?


On Sat, Oct 24, 2015 at 5:41 PM, Vishwas Manral <> wrote:
Also ATS version is 5.3.1.


On Sat, Oct 24, 2015 at 5:39 PM, Vishwas Manral <> wrote:
Thanks Shu Kit for the very prompt response. 

My script is not being called at all for HTTPS - it does get called for HTTP - that is the problem I am trying to resolve. I tried just map/ map_with recv_port and other options but the same result.


On Sat, Oct 24, 2015 at 5:36 PM, Shu Kit Chan <> wrote:
Perhaps you can turn on the debug to see what's going on and whether the script is actually being called or not.
You can use ts.debug() in the lua script to print out something out to help you debug as well.

Also, perhaps you can share what "x.lua" is doing so that we can know more about your use case?



On Sat, Oct 24, 2015 at 5:20 PM, Vishwas Manral <> wrote:

I was trying to use ATS 5.1.0 as a reverse proxy.

I am able to remap HTTP traffic however not able to do the same for HTTPS using the tslua plugin. If I put code pointer in plugin.config that code is invoked - while the rules of remap.config do not work. The rules are as below:

regex_map_with_recv_port http://.*:<port number1> http://.*:<port number1> @plugin=/opt/ats/libexec/trafficserver/ @pparam=x.lua @pparam=MON

regex_map_with_recv_port https://.*:<port number2> https://.*: <port number2> @plugin=/opt/ats/libexec/trafficserver/ @pparam=x.lua @pparam=MON

The first one works the second doesn't. The diag seems to say the certs are loaded correctly

[Oct 24 23:59:07.191] Server {0x2b1b1a82XXXX} NOTE: loading SSL certificate configuration from /opt/ats/etc/trafficserver/ssl_multicert.config

What could I be doing wrong?