trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From salil GK <gksa...@gmail.com>
Subject Re: Facing problem in running ATS
Date Mon, 16 Jan 2017 23:08:49 GMT
I have stopped the other instance that is running ( 26997 ). Then I tried
to run this command. Then I am getting a core dump of traffic_server
>>>>

~/apns/etc # env | grep TS

TS_ROOT=/tandberg/apns/

~/apns/etc # /trafficserver/bin/traffic_manager

[E. Mgmt] log ==> [TrafficManager] using root directory '/tandberg/apns'

traffic_server: using root directory '/tandberg/apns'

FATAL: unable to load '/tandberg/apns/libexec/trafficserver/libloader.so':
/tandberg/apns/libexec/trafficserver/libloader.so: cannot open shared
object file: No such file or directory

traffic_server: Aborted (Signal sent by tkill() 9792 0)

traffic_server - STACK TRACE:

/trafficserver/bin/traffic_server(_Z19crash_logger_invokeiP9siginfo_tPv+0xed)[0x55d9a6da82fc]

/lib/x86_64/libpthread.so.0(+0x11c20)[0x2b7bc01afc20]

/lib/x86_64/libc.so.6(gsignal+0xff)[0x2b7bc0b1307f]

/lib/x86_64/libc.so.6(abort+0x181)[0x2b7bc0b146e1]

/lib/x86_64/libtsutil.so.6(_Z12ink_fatal_vaPKcP13__va_list_tag+0x0)[0x2b7bbe498f77]

/lib/x86_64/libtsutil.so.6(_Z9ink_fatalPKcz+0x0)[0x2b7bbe499054]

/lib/x86_64/libtsutil.so.6(_ZNK5Diags8error_vaE10DiagsLevelPKcS2_iS2_P13__va_list_tag+0x121)[0x2b7bbe4807a3]

/trafficserver/bin/traffic_server(_ZNK5Diags5errorE10DiagsLevelPKcS2_iS2_z+0xe2)[0x55d9a6d90e66]

/trafficserver/bin/traffic_server(+0x16a5ae)[0x55d9a6dec5ae]

/trafficserver/bin/traffic_server(_Z11plugin_initb+0x3ee)[0x55d9a6decdcd]

/trafficserver/bin/traffic_server(main+0x1092)[0x55d9a6de3433]

/lib/x86_64/libc.so.6(__libc_start_main+0x114)[0x2b7bc0aff314]

/trafficserver/bin/traffic_server(_start+0x2a)[0x55d9a6d8ed9a]

traffic_server: using root directory '/tandberg/apns'

^C[TrafficManager] ==> Cleaning up and reissuing signal #2

[TrafficManager] ==> signal #2

<<<<

Not sure why it is looking for
/tandberg/apns/libexec/trafficserver/libloader.so.
all libraries are under /trafficserver/libexec. Is there any setting that I
need to specify for pointing to the lib location ?


Regards

~S

On 17 January 2017 at 04:34, salil GK <gksalil@gmail.com> wrote:

> Thanks for the help
>
> I tried to run traffic_server program also ad it gives the same result
>
> >>>>
>
> export TS_ROOT=/tandberg/apns/; /trafficserver/bin/traffic_server
>
> traffic_server: using root directory '/tandberg/apns'
>
> WARNING: Can't acquire lockfile '/tandberg/trafficserver/var/trafficserver/server.lock'
> (Lock file held by process ID 26997)
>
> <<<<
>
> Nowhere in my configuration files under /tandberg/apns
> /tandberg/trafficserver is mentioned. But original configuration location
> set during compilation is /tandberg/trafficserver .
>
>
> Regards
>
> ~S
>
> On 17 January 2017 at 01:46, Jack Bates <duhapa@nottheoilrig.com> wrote:
>
>> Sorry, I don't have a good answer:
>> I just ran the following and it worked for me:
>>
>>   $ TS_ROOT=~/Desktop/TS_ROOT cmd/traffic_manager/traffic_manager
>>
>> Can you maybe try running the following?
>> I hope it will narrow down the problem.
>>
>>   # TS_ROOT=/tandberg/apns /trafficserver/bin/traffic_server
>>
>> Is /tandberg/trafficserver mentioned anywhere in your config?
>>
>>
>> On 16/01/17 09:28 AM, salil GK wrote:
>>
>>> Hi,
>>>
>>>    I am trying to run ATS by exporting TS_ROOT variable to a different
>>> location. I am running ATS using trffic_manager binary.
>>>
>>> but while runnig the following is what I am getting on console..
>>>
>>>
>>>>>
>>> ~ # /trafficserver/bin/traffic_manager
>>>
>>> [E. Mgmt] log ==> [TrafficManager] using root directory '/tandberg/apns'
>>>
>>> FATAL: Lockfile '/tandberg/trafficserver/var/trafficserver/server.lock'
>>> says server already running as PID 26997
>>>
>>> [Jan 16 15:53:59.646] Manager {0x7f8752580740} ERROR: FATAL: Lockfile
>>> '/tandberg/trafficserver/var/trafficserver/server.lock' says server
>>> already running as PID 26997
>>>
>>> [Jan 16 15:53:59.646] Manager {0x7f8752580740} ERROR: FATAL: Lockfile
>>> '/tandberg/trafficserver/var/trafficserver/server.lock' says server
>>> already running as PID 26997
>>>
>>> ~ #
>>>
>>> <<<
>>>
>>> What could be the issue ?
>>>
>>> PS: I have set 'CONFIG proxy.config.config_dir STRING
>>> /tandberg/apns/etc' also
>>>
>>>
>>> Thanks and regards
>>>
>>> Also I made complete copy of all configuration file under
>>> /tandberg/apns/.
>>>
>>> ~S
>>>
>>>
>>>
>

Mime
View raw message