trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Payne <jp557...@gmail.com>
Subject Re: Cannot getting actual response in escalate plugin
Date Fri, 26 Oct 2018 20:11:38 GMT
I have only tested 404 and 5xx response fail over.
It looks like you need to cover other 4xx response codes.
Not sure if parent selection will fail over on 401, etc.
It's worth a try though, since sometimes documentation and reality can
differ - in either way :-)..

List your origins as primary/secondary.

https://docs.trafficserver.apache.org/en/8.0.x/admin-guide/files/parent.config.en.html?highlight=parent%20config
On Fri, Oct 26, 2018 at 1:24 PM Vasanth Mathivanan
<vasanth.m@evolutiondigital.com> wrote:
>
> I had two origin servers  not traffic server , is this possible on parent plugin  ?
>
>
>
> “dest_domain=x.x.x.x. port=81 method=get parent="10.137.10.174:8087|1.0; 10.137.10.173:8003|2.0"
round_robin=consistent_hash”
>
>
>
>
>
> __Vasanth
>
>
>
> Sent from Mail for Windows 10
>
>
>
> From: Jeremy Payne
> Sent: Friday, October 26, 2018 10:19 PM
> To: users@trafficserver.apache.org
> Subject: Re: Cannot getting actual response in escalate plugin
>
>
>
> The same functionality is in parent selection.
>
> Try both and compare.
>
> On Fri, Oct 26, 2018, 11:29 AM Vasanth Mathivanan <vasanth.m@evolutiondigital.com>
wrote:
>>
>> Hi,
>>
>>
>>
>> getting every response 80 and 81 , but our origin server having only 81 port and
give it also parameters , so its came all requests from both port .if i give 80 port in escalate
plugin its working but slow requests and sometimes struck.
>>
>>
>>
>> if I give pristine parameter ,then its calling differently came  , I have posted
that logs also .
>>
>> Anyone can fix the issue ?
>>
>>
>>
>>
>>
>> map     http://x.x.x.x:8087/     http://y.y.y.y  @plugin=header_rewrite.so @pparam=dscp/set_dscp_32.config
@plugin=header_rewrite.so @pparam=hdr_rw_live.config @plugin=background_fetch.so @pparam=bg_fetch.config
@plugin=collapsed_forwarding.so @plugin=tslua.so @pparam=/opt/trafficserver/libexec/trafficserver/cache.lua
/opt/trafficserver/libexec/trafficserver/lua_test.lua
>>
>>   @plugin=escalate.so @pparam=401,404,410,502:z.z.z.z:81
>>
>>
>>
>> logs:
>>
>>
>>
>> 1540545320.305 chi=192.168.1.178 phn=wow-den-stremer174 php=0 shn=z.z.z.z:81 url=http://x.x.x.x:8087/EvoLive/FOODHD/FOODHD_854x396_high_1200.m3u8
cqhm=GET cqhv=HTTP/1.1 pssc=404 ttms=0 b=0 sssc=404 sscl=0 cfsc=FIN pfsc=FIN crc=TCP_MISS_X_REDIRECT
phr=DIRECT pqsn=50.224.139.77 uas="Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36
(KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063"
>>
>> 1540545320.326 chi=192.168.1.178 phn=wow-den-stremer174 php=0 shn=z.z.z.z url=http://x.x.x.x:8087/EvoLive/FOODHD/FOODHD_854x396_high_1200.m3u8
cqhm=GET cqhv=HTTP/1.1 pssc=206 ttms=24 b=1757 sssc=206 sscl=1757 cfsc=FIN pfsc=FIN crc=TCP_MISS
phr=DIRECT pqsn=z.z.z.z uas="Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36
(KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063"
>>
>>
>>
>> logs with pristine:
>>
>>
>>
>> 1540539525.614 chi=192.168.1.178 phn=wow-den-stremer174 php=8087 shn=z.z.z.z:81:8087
url=http://z.z.z.z:81:8087/EvoLive/FOODHD/FOODHD.m3u8 cqhm=GET cqhv=HTTP/1.1 pssc=502 ttms=60043
b=391 sssc=404 sscl=0 cfsc=FIN pfsc=FIN crc=ERR_CONNECT_FAIL phr=NONE pqsn=z.z.z.z:81:8087
uas="Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116
Safari/537.36 Edge/15.15063"
>>
>> 1540543737.423 chi=192.168.1.178 phn=wow-den-stremer174 php=8087 shn=y.y.y.y url=http://z.z.z.z:81:8087/EvoLive/FOODHD/FOODHD.m3u8
cqhm=GET cqhv=HTTP/1.1 pssc=404 ttms=0 b=0 sssc=404 sscl=0 cfsc=FIN pfsc=FIN crc=TCP_MISS_X_REDIRECT
phr=DIRECT pqsn=y.y.y.y uas="Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36
(KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063"
>>
>>
>>
>> __Vasanth
>>
>>
>>
>> Sent from Mail for Windows 10
>>
>>

Mime
View raw message