trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Chaves <e...@uolet.com>
Subject Re: No traffic.out file
Date Wed, 06 Mar 2019 14:55:25 GMT
Hi Jason, you are correct, the DEBUG messages are being sent to console,
thanks! Just for the record, I've checked diags.log but there was no
message from ts.debug there either.  I'm actually running traffic_manager
which I assume starts traffic_server. Since I'm running it inside a docker
container grabbing the output was easy using docker logs =). Ayway would be
nice to learn why the traffic.out is not being produced? Is this something
ATS changed recently or does it require a special build/config?

Once again, thanks for the tip. =)


Em qua, 6 de mar de 2019 às 11:33, Jason Yang <peter.waynechina@gmail.com>
escreveu:

> I am also new to ATS, so the answer might not be correct.
> Have you checked var/log/trafficserver/diags.log? Also I think when you
> run traffic_server instead trafficserver, it will print to console.
>
>
> Jason
>
> On Mar 6, 2019, 09:28 -0500, Eric Chaves <eric@uolet.com>, wrote:
>
> Hi community,
>
> I once again reach out for with another newbie question =) I'm playing
> around with lua scripts but for some reason my ATS does not output ts.debug
> messages to the traffic.out (which by the way is missing and not being
> created automatically).
>
> I've checked that proxy.config.diags.debug.enabled is enabled (set to 1)
> and I've also added some extras tag to proxy.config.diags.debug.tags
> (currently setted as my_lua|ts_lua|http|dns).
>
> Apart from those settings is there any other settings I should set in
> order to have debug messages sent  to traffic.out file?
>
> Best regards,
>
>

Mime
View raw message