trafodion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Birdsall <dave.birds...@esgyn.com>
Subject RE: Where are the logs for the first set of regression tests?
Date Tue, 04 Aug 2015 16:26:20 GMT
Right. Start with the simple stuff I think. Eric's e-mail trail is valuable
as it is fresh newbie experience; if we could answer Eric's questions on the
wiki I think that would be a great start.

-----Original Message-----
From: Sandhya Sundaresan [mailto:sandhya.sundaresan@esgyn.com]
Sent: Tuesday, August 4, 2015 9:24 AM
To: dev@trafodion.incubator.apache.org
Subject: RE: Where are the logs for the first set of regression tests?

Hi Eric, Dave,

  I can  add a page to the wiki for this.  We did have the steps documented
in our old internal wiki for those starting on Trafodion for the first time.
Also Roberta had a comprehensive  document describing the whole regress
environment back in MX days , I think. Not sure if anyone has that saved.
Either way, for the wiki, perhaps a smaller page would be sufficient.

Thanks
Sandhya

-----Original Message-----
From: Eric Owhadi [mailto:eric.owhadi@esgyn.com]
Sent: Tuesday, August 4, 2015 9:03 AM
To: dev@trafodion.incubator.apache.org
Subject: RE: Where are the logs for the first set of regression tests?

I didn't want to ask, but indeed that would be fantastic and time saving.
Also how to write and/or modify when tests are complaining, but we know that
this is just because regression is based on delta, and cannot recognize
legitimate expected delta (due to know feature we just implemented), and
real regression.
Eric

-----Original Message-----
From: Dave Birdsall [mailto:dave.birdsall@esgyn.com]
Sent: Tuesday, August 4, 2015 10:21 AM
To: dev@trafodion.incubator.apache.org
Subject: RE: Where are the logs for the first set of regression tests?

Do we have a page on our Apache Trafodion wiki that describes how to run the
regression tests and how to interpret and deal with the results? If someone
would like to volunteer to write such a page, it would be very useful to
newbies, I think.

-----Original Message-----
From: Eric Owhadi [mailto:eric.owhadi@esgyn.com]
Sent: Tuesday, August 4, 2015 7:45 AM
To: dev@trafodion.incubator.apache.org
Subject: RE: Where are the logs for the first set of regression tests?

Thanks Suresh, that's it indeed :-). Was driving me crazy.
Eric

-----Original Message-----
From: Suresh Subbiah [mailto:suresh.subbiah60@gmail.com]
Sent: Tuesday, August 4, 2015 9:41 AM
To: dev@trafodion.incubator.apache.org
Subject: Re: Where are the logs for the first set of regression tests?

Hi Eric,

I think the "first" set of tests is the same as the last set. This is an
artifact of how runallsb prints out results. At the end of every suite a
summary of that suite is printed out (with no header what suite it refers to
since we have been running that suite for the last X minutes). Then at the
end of a run it concatenates the summary of every suite, this time with a
header for each suite. So if you kick off regressions now and come back
several hours later there will be a screen with a summary for all suites and
then before the summary for core there will be list of results with no suite
name. This is the same as the last suite in the summary (the hive test
suite).

Thanks
Suresh


On Tue, Aug 4, 2015 at 9:20 AM, Qifan Chen <qifan.chen@esgyn.com> wrote:

> Hi Eric,
>
> The results should be in one of the directories under $rundir.  For
> example, under $rundir/core, the result for TEST001 (under
> $scriptsdir/core) is LOG001.
>
> In my ~/.bashrc file, I have these two variables defined.
>
> export rundir=/mnt/qfc/rundir
>
> export scriptsdir=$trafodionRoot/sql/regress
>
>
> After mkdir $rundir, make sure $rundir contains directories, one for
> each category in $scriptsdir.  Once it is setup, you can run
> regressions as many times as you want :-)
>
> On Tue, Aug 4, 2015 at 9:01 AM, Eric Owhadi <eric.owhadi@esgyn.com> wrote:
>
> > That may be an obvious question, but I can’t find the logs and diffs
> > for the first set of test showing up in the result of the runallsb:
> >
> > I can see all the logs and diffs for categories like core,
> > compGeneral
> etc,
> > but the first set of test labelled:
> >
> > TEST001
> >
> > TEST002
> >
> > TEST003
> >
> > TEST004
> >
> > TEST005
> >
> > TEST006
> >
> > TEST015
> >
> > TEST017
> >
> > TEST018
> >
> > TEST020
> >
> >
> >
> > are not associated with a category, and they don’t have a
> > subdirectory
> with
> > categoryname where I can find the other test results.
> >
> > Thanks in advance for the help.
> >
> >
> >
> > As a side note, if a test fails because of the compare, but the
> > delta is legit, what should one do? Update known diffs? Or set a new
> > compare file?
> >
> >
> >
> > Eric
> >
>
>
>
> --
> Regards, --Qifan
>

Mime
View raw message