trafodion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amanda Moran <amanda.mo...@esgyn.com>
Subject Re: sqstart fails
Date Thu, 27 Aug 2015 16:10:10 GMT
Can you try *sudo sysctl -q kernel.pid_max* on all nodes?

FYI: sudo sysctl -w kernel.pid_max=65535 (is what it should be set to).

Thanks!



On Thu, Aug 27, 2015 at 9:05 AM, Radu Marias <radumarias@gmail.com> wrote:

> These lines are from the install process:
>
> *pdcp@node5: can't stat /home/trafodion/sqcert*
> *pdcp@node5: can't stat shell.env*
> *pdcp@node5: can't stat mon.env*
>
>
> On Thu, Aug 27, 2015 at 7:04 PM, Radu Marias <radumarias@gmail.com> wrote:
>
> > Hi,
> >
> > I have a cluster of 5 nodes, each as a virtual machine.
> > This is on them:
> > Centos 7
> > Ambari 2.1
> > HDP 2.2
> > jdk1.7.0_67, installed by ambari
> >
> > I managed to run the installer with success (though some warning were
> > present, see bellow). When I try to run sqstart then as trafodion user it
> > fails.
> >
> > Processing cluster.conf on local host node5
> > [SHELL] Shell/shell Version 1.0.1 Release 1.2.0 (Build release
> > [1.0.0_core-1121-g5928f31_Bld184], date 20150827_083009)
> > ^[[?1034h
> > [SHELL] %
> > ! Start the monitor processes across the cluster
> > startup
> > [SHELL] %startup
> > [SHELL] Unable to communicate with monitor because monitor port file
> > /home/trafodion/trafodion-20150827_0830/tmp/monitor.port.node5 is
> missing.
> > [SHELL] Failed to start environment!
> >
> > [SHELL] %
> > exit
> > [SHELL] %exit
> > Trying to connect to the SQ monitor ..........
> > There seems to be a problem connecting to the SQ monitor.
> > Aborting startup.
> > /logs/sqcheckmon.log: No such file or directory
> > Error while executing the startup script!!!
> >
> > Please check the SQ shell log file :
> > /home/trafodion/trafodion-20150827_0830/logs/sqmon.log
> >
> > SQ Startup (from /home/trafodion/trafodion-20150827_0830/sql/scripts)
> > Failed
> >
> > Checking if processes are up.
> > ^MChecking attempt: 1; user specified max: 2. Execution time in seconds:
> 4.
> >
> > The SQ environment is not up all, or partially up and not operational.
> > Check the logs.
> >
> > Process         Configured      Actual      Down
> > -------         ----------      ------      ----
> > DTM             5               0           \$TM0 \$TM1 \$TM2 \$TM3 \$TM4
> > RMS             10              0           \$ZSC000 \$ZSC001 \$ZSC002
> > \$ZSC003 \$ZSC004 \$ZSM000 \$ZSM001 \$ZSM002 \$ZSM003 \$ZSM004
> > MXOSRVR         2               0           2
> >
> >
> > The SQ environment is down.]
> > Zookeeper is listening on port 2181
> > Dcs Master is not started ...
> >
> > Attached are some logs.
> >
> > I also did *sqgen* but the same. Also tried *ckillall* and restarted
> > hbase server between multiple starts.
> > I have *log4cxx* installed.
> >
> > --
> > And in the end, it's not the years in your life that count. It's the life
> > in your years.
> >
>
>
>
> --
> And in the end, it's not the years in your life that count. It's the life
> in your years.
>



-- 
Thanks,

Amanda Moran

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message