trafodion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amanda Moran <amanda.mo...@esgyn.com>
Subject Re: install trafodion on hdp 2.3
Date Fri, 21 Aug 2015 20:17:48 GMT
The installer will need a very small change to support HDP 2.3 but
Trafodion will need larger changes to support HBase 1.0+.

Others can chime in on the changes we would need to support HBase 1.0+.

Thanks!

On Fri, Aug 21, 2015 at 1:11 PM, Radu Marias <radumarias@gmail.com> wrote:

> It could be just a matter of installer and maybe we could change it to
> support hdp 2.3 also? Or there are also changes to the libraries and
> configs that are added to hadoop env on install?
>
> On Fri, Aug 21, 2015, 21:54 Amanda Moran <amanda.moran@esgyn.com> wrote:
>
> > Great find Radu! Thank you!! Yes, that is a bug for sure.
> >
> > I created a JIRA: https://issues.apache.org/jira/browse/TRAFODION-1461
> >
> > Here is the information on how to check in your change:
> >
> > https://wiki.trafodion.org/wiki/index.php/Contributor_Workflow
> >
> > On Fri, Aug 21, 2015 at 6:08 AM, Radu Marias <radumarias@gmail.com>
> wrote:
> >
> > > Also found a bug in installer script when checking the Hadoop version,
> it
> > > only works with default username and password as admin:admin.
> > > This is because in some places there are some *admin:admin* as
> > > username:password hard coded when checking the Hadoop version like
> > > curl -su admin:admin http://$URL/api/v1/clusters
> > >
> > > Attached is the fixed version of *traf_config_setup* script.
> > >
> > > With this fix (or default username and :password) indeed it checks for
> > HDP
> > > 2.2, and fails. So I assume it's better not to change the scripts for
> > > allowing install also on 2.3 for now until you guys test trafodion for
> > HDP
> > > 2.3.
> > >
> > > On Fri, Aug 21, 2015 at 3:04 PM Radu Marias <radumarias@gmail.com>
> > wrote:
> > >
> > >> Is trafodion installer suppose to work with *Apache Ambari 2.1.0* and
> > >> *HDP-2.3.0.0-2557*?
> > >>
> > >> I'm trying to install the latest daily build of trafodion (
> > >> *installer-20150821_0830.tar.gz*) on this stack and get these errors
> > >> after I provide the Hadoop external network URL:port
> > >>
> > >> ***ERROR: Hadoop type can not be determined
> > >> ***ERROR: Check that URL and port are correct or if Hadoop is up
> > >> ***ERROR: Error while running traf_config_setup.
> > >> ***ERROR: No configuration file created.
> > >>
> > >> Or I need to stick to HDP 2.2 as in the sandbox?
> > >>
> > >> --
> > >> And in the end, it's not the years in your life that count. It's the
> > life
> > >> in your years.
> > >>
> > >
> >
> >
> > --
> > Thanks,
> >
> > Amanda Moran
> >
>



-- 
Thanks,

Amanda Moran

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message