trafodion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Birdsall <dave.birds...@esgyn.com>
Subject RE: initialize trafodion after upgrade
Date Tue, 09 Feb 2016 20:43:20 GMT
Hi,

I found a script, "update_hbase", in the sql/scripts directory. Tried
running that. No luck.

Anu suggested to me that I delete what was under the "hdfs:" subdirectory in
the local_hadoop directory. No luck either.

Finally went for the gold and did swuninstall_local_hadoop followed by
install_local_hadoop. That worked.

Thanks to all who helped.

Dave

-----Original Message-----
From: Roberta Marton [mailto:roberta.marton@esgyn.com]
Sent: Tuesday, February 9, 2016 12:17 PM
To: dev@trafodion.incubator.apache.org
Subject: RE: initialize trafodion after upgrade

I had the same issue yesterday but was not sure if it was my problem (I am
fixing some data corruption issues).
Anyway, I ended up uninstalling and reinstalling the Hadoop eco-system to
get things to work again.  Also rebuilt everything.  Hopefully, there is a
better solution.

     Roberta

-----Original Message-----
From: Dave Birdsall [mailto:dave.birdsall@esgyn.com]
Sent: Tuesday, February 9, 2016 12:03 PM
To: dev@trafodion.incubator.apache.org
Subject: initialize trafodion after upgrade

Hi,



This morning I brought an existing development instance up-to-date (did the
git fetch –all, and created a new branch, did an sqstop, make clean, make
all).



When I brought the instance back up, it complained that I needed to do an
initialize trafodion, drop + an initialize trafodion.



I did the initialize trafodion, drop without problems.



But the initialize  trafodion fails as follows:



Apache Trafodion Conversational Interface 2.0.0

Copyright (c) 2015 Apache Software Foundation

>>initialize trafodion;



*** ERROR[8448] Unable to access Hbase interface. Call to
ExpHbaseInterface::create() returned error HBASE_CREATE_ERROR(701). Cause:

java.lang.NullPointerException

java.lang.String.contains(String.java:2076)

org.trafodion.sql.CoprocessorUtils.addCoprocessor(CoprocessorUtils.java:76)

org.trafodion.sql.HBaseClient.createk(HBaseClient.java:490)

.



--- SQL operation failed with errors.

>>exit;



So, I’m guessing the coprocessor jars need to be brought up-to-date. Is
there a convenient script to do this? Or must I bite the bullet and do a
swuninstall + install_local_hadoop?



Thanks,



Dave

Mime
View raw message