trafodion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Liu, Ming (Ming)" <ming....@esgyn.cn>
Subject 答复: Error building Trafodion
Date Sat, 27 Feb 2016 03:32:16 GMT
Hi, Nitin,

I run into same error last week when I tried to use CentOS 7 as my Development machine. The
default GCC on CentOS 7 is GCC4.8, it seems incompatible.
For this particular issue, I modified the Makefile under 
   incubator-trafodion/core/dbsecurity/auth/Makefile
to add '-llber' into LINK_OPTIONS
And pass this error.
I have no idea why current building workstation not meet this link error, I have no theory
here :-) I have another CentOS 6.5 workstation, same codebase, but not meet this build error.
It is still a mystery for me. Need time to investigate more.

But if I you are using GCC 4.8, the building will meet few more errors after solving this
issue. I fixed a few, but still some more are there, and not able to proceed too much up to
now. So I think if you are using gcc 4.8, please consider to use an older version. CentOS
6.5 ship with GCC 4.4, which is fine.  

In sum, if you are not using CentOS 6, please use CentOS 6.x as development workstation will
save you a lot of time, it is well tested.

Thanks,
Ming

-----邮件原件-----
发件人: Nitin Lamba [mailto:nitin@ampool.io] 
发送时间: 2016年2月27日 11:00
收件人: dev@trafodion.incubator.apache.org
抄送: Steve Varnau <steve.varnau@esgyn.com>
主题: Error building Trafodion

Hi,


I tried to build Trafodion by following the instructions on the wiki [1], [2] using 'make
all'. However, I ran into an error compiling 'auth' within dbsecurity - log excerpt below:


[... SNIPPET ...]

cd auth; make ##(Security)

make[3]: Entering directory `/home/nitinlamba/incubator-trafodion/core/dbsecurity/auth' ##(Security)

/usr/bin/g++  -DSQ_PHANDLE_VERIFIER -fPIC -g   -m64 -DNA_LINUX -DNA_64BIT -o /home/nitinlamba/incubator-trafodion/core/sqf/export/bin64/ldapcheck
-I. -I./inc -I ../shared/inc -I /home/nitinlamba/incubator-trafodion/core/sqf/../sql/cli -I
/home/nitinlamba/incubator-trafodion/core/sqf/../sql/common -I /home/nitinlamba/incubator-trafodion/core/sqf/../sql/executor
-I /home/nitinlamba/incubator-trafodion/core/sqf/../sql/export -I /home/nitinlamba/incubator-trafodion/core/sqf/../sql/porting_layer
-I /home/nitinlamba/incubator-trafodion/core/sqf/export/include -I ../../sql/common -L/home/nitinlamba/incubator-trafodion/core/sqf/export/lib64
-lldap -lssl   Linux-x86_64/64/rls/ldapconfignode.o Linux-x86_64/64/rls/versldapcheck.o Linux-x86_64/64/rls/ldapcheck.o
Linux-x86_64/64/rls/ldapconfigfile.o   ##(Security)

/usr/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/4.8.5/../../../../lib64/libldap.so: undefined
reference to symbol 'ber_set_option' ##(Security)

/usr/bin/ld: note: 'ber_set_option' is defined in DSO /lib64/liblber-2.4.so.2 so try adding
it to the linker command line ##(Security)

/lib64/liblber-2.4.so.2: could not read symbols: Invalid operation ##(Security)

collect2: error: ld returned 1 exit status ##(Security)

make[3]: *** [/home/nitinlamba/incubator-trafodion/core/sqf/export/bin64/ldapcheck] Error
1 ##(Security)

make[3]: Leaving directory `/home/nitinlamba/incubator-trafodion/core/dbsecurity/auth' ##(Security)

make[2]: *** [auth] Error 2 ##(Security)

make[2]: Leaving directory `/home/nitinlamba/incubator-trafodion/core/dbsecurity' ##(Security)

make[1]: *** [dbsecurity] Error 2


Any ideas what I could be doing wrong?


Thanks,

Nitin


[1] https://cwiki.apache.org/confluence/display/TRAFODION/Create+Build+Environment

[2] https://cwiki.apache.org/confluence/display/TRAFODION/Build+Source

Mime
View raw message