trafodion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitin Lamba <ni...@ampool.io>
Subject Re: Error building Trafodion
Date Sat, 27 Feb 2016 03:32:38 GMT
Forgot to mention my environment - I'm running the latest CentOS 7.2:

$ cat /etc/centos-release
CentOS Linux release 7.2.1511 (Core)

Nitin

________________________________________
From: Nitin Lamba <nitin@ampool.io>
Sent: Friday, February 26, 2016 6:59 PM
To: dev@trafodion.incubator.apache.org
Cc: steve.varnau@esgyn.com
Subject: Error building Trafodion

Hi,


I tried to build Trafodion by following the instructions on the wiki [1], [2] using 'make
all'. However, I ran into an error compiling 'auth' within dbsecurity - log excerpt below:


[... SNIPPET ...]

cd auth; make ##(Security)

make[3]: Entering directory `/home/nitinlamba/incubator-trafodion/core/dbsecurity/auth' ##(Security)

/usr/bin/g++  -DSQ_PHANDLE_VERIFIER -fPIC -g   -m64 -DNA_LINUX -DNA_64BIT -o /home/nitinlamba/incubator-trafodion/core/sqf/export/bin64/ldapcheck
-I. -I./inc -I ../shared/inc -I /home/nitinlamba/incubator-trafodion/core/sqf/../sql/cli -I
/home/nitinlamba/incubator-trafodion/core/sqf/../sql/common -I /home/nitinlamba/incubator-trafodion/core/sqf/../sql/executor
-I /home/nitinlamba/incubator-trafodion/core/sqf/../sql/export -I /home/nitinlamba/incubator-trafodion/core/sqf/../sql/porting_layer
-I /home/nitinlamba/incubator-trafodion/core/sqf/export/include -I ../../sql/common -L/home/nitinlamba/incubator-trafodion/core/sqf/export/lib64
-lldap -lssl   Linux-x86_64/64/rls/ldapconfignode.o Linux-x86_64/64/rls/versldapcheck.o Linux-x86_64/64/rls/ldapcheck.o
Linux-x86_64/64/rls/ldapconfigfile.o   ##(Security)

/usr/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/4.8.5/../../../../lib64/libldap.so: undefined
reference to symbol 'ber_set_option' ##(Security)

/usr/bin/ld: note: 'ber_set_option' is defined in DSO /lib64/liblber-2.4.so.2 so try adding
it to the linker command line ##(Security)

/lib64/liblber-2.4.so.2: could not read symbols: Invalid operation ##(Security)

collect2: error: ld returned 1 exit status ##(Security)

make[3]: *** [/home/nitinlamba/incubator-trafodion/core/sqf/export/bin64/ldapcheck] Error
1 ##(Security)

make[3]: Leaving directory `/home/nitinlamba/incubator-trafodion/core/dbsecurity/auth' ##(Security)

make[2]: *** [auth] Error 2 ##(Security)

make[2]: Leaving directory `/home/nitinlamba/incubator-trafodion/core/dbsecurity' ##(Security)

make[1]: *** [dbsecurity] Error 2


Any ideas what I could be doing wrong?


Thanks,

Nitin


[1] https://cwiki.apache.org/confluence/display/TRAFODION/Create+Build+Environment

[2] https://cwiki.apache.org/confluence/display/TRAFODION/Build+Source

Mime
View raw message