trafodion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre Smits <pierre.sm...@gmail.com>
Subject Re: 答复: Trafodion 2.0 & Java
Date Sat, 02 Apr 2016 10:54:13 GMT
Hi all,

That is why it is important to:

   - plan for this; - JIRA will facilitate this
   - built hypothesis in separate dev branches - GIT will facilitate this
   - and test - CI will facilitate this

We not only have to deal with 1.7 (current), 1.8 (near future), but also
1.9 (whenever).

Best regards

Pierre Smits

ORRTIZ.COM <http://www.orrtiz.com>
OFBiz based solutions & services

OFBiz Extensions Marketplace
http://oem.ofbizci.net/oci-2/

On Sat, Apr 2, 2016 at 12:41 PM, Liu, Ming (Ming) <ming.liu@esgyn.cn> wrote:

> Now Trafodion can work with openJDK 1.7 and SunJDK 1.7, both are fine, so
> I assume it will remain same in 1.8, but we have to test, hard to say now.
>
> It seems HBase support JDK 1.8 from newly released HBase 1.2. And
> Trafodion is now working on HBase 0.98 and Trafodion 2.0 will support HBase
> 1.1, but since HBase API stay compatible after HBase 1.0, so moving to
> HBase 1.2 should take less effort than before. But IMHO, HBase 1.1 cannot
> run with JDK 1.8? If that is correct, I think we cannot change to JDK 1.8,
> since Trafodion have some coprocessor to be loaded by HBase RS, I assume a
> jar built with JDK 1.8 may have problems to be loaded by a Java program
> built with JDK 1.7.
> But if Trafodion 2.0 can support HBase 1.2, I think move to JDK 8 will be
> a good idea. But that is not what we originally planned (HBase 1.2), so
> maybe this will postpone the release of Trafodion 2.0? So need Steve to
> consider it more.
>
> But I strongly vote to Pierre that Trafodion should start planning for JDK
> 8.
>
> Currently, Trafodion java src code cannot directly built with JDK 8, I
> remember Nitin once gave a very good suggestion to change an java build
> option, I would like to follow Nitin's suggestion and do some initial
> investigation.
>
> JDK change should be a major change, need more careful consideration of
> all. We should understand all side effort of it before we can made the
> change. The major concern is compatibility of various components, not only
> Trafodion, but also HDFS, HBase, Zookeeper, Hive, etc... If all are moved
> to JDK 8, Trafodion should follow of course.
>
> Thanks,
> Ming
>
> -----邮件原件-----
> 发件人: Avinash Dongre [mailto:avinash@ampool.io]
> 发送时间: 2016年4月2日 18:13
> 收件人: dev@trafodion.incubator.apache.org
> 主题: Re: Trafodion 2.0 & Java
>
> 1.8 should be from openJDK or SunJDK is fine ?
>
> ________________________________________
> From: Selva Govindarajan <selva.govindarajan@esgyn.com>
> Sent: 02 April 2016 07:27
> To: dev@trafodion.incubator.apache.org
> Subject: RE: Trafodion 2.0 & Java
>
> Yes., maven build scripts need some changes for some of the Trafodion
> components java programs to compile.
>
> Selva
> -----Original Message-----
> From: Amanda Moran [mailto:amanda.moran@esgyn.com]
> Sent: Friday, April 1, 2016 5:09 PM
> To: dev@trafodion.incubator.apache.org
> Subject: Re: Trafodion 2.0 & Java
>
> We can run with 1.7 or 1.8 but building is probably very different.
>
> Thanks!
>
> Sent from my iPhone
>
> > On Apr 1, 2016, at 5:07 PM, Steve Varnau <steve.varnau@esgyn.com> wrote:
> >
> > Pierre,
> >
> > We have long required Java 1.7, I don't know that anyone has tested
> > with 1.8.
> >
> > --Steve
> >
> >> -----Original Message-----
> >> From: Pierre Smits [mailto:pierre.smits@gmail.com]
> >> Sent: Friday, April 1, 2016 9:09 AM
> >> To: dev@trafodion.incubator.apache.org
> >> Subject: Trafodion 2.0 & Java
> >>
> >> Hi all,
> >>
> >> Is Trafodion 2.0. a JAVA 8 solution? Or?
> >>
> >> Best regards,
> >>
> >> Pierre Smits
> >>
> >> ORRTIZ.COM <http://www.orrtiz.com>
> >> OFBiz based solutions & services
> >>
> >> OFBiz Extensions Marketplace
> >> http://oem.ofbizci.net/oci-2/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message