trafodion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Birdsall <>
Subject RE: A heads-up about a recent pull request
Date Thu, 12 Sep 2019 05:28:34 GMT
Hi Zalo,


And BTW, reinstalling local Hadoop worked for me as expected. My Trafodion instance came up


-----Original Message-----
From: Zalo Correa <> 
Sent: Wednesday, September 11, 2019 6:27 PM
Subject: RE: A heads-up about a recent pull request


The changes require that Hadoop be uninstalled and reinstalled. The conf directory, configuration
files, is now copied to the local_hadoop/traf_conf directory by Hadoop installation script.


-----Original Message-----
From: Dave Birdsall <>
Sent: Wednesday, September 11, 2019 5:59 PM
Subject: A heads-up about a recent pull request



I recently merged a pull request:

I'm noticing one side effect from this pull request. I had a successful Trafodion development
instance, using local Hadoop, based on code before this pull request.

I did an sqstop + swstophbase. Then I did a git fetch origin, picking up Zalo's change, then
created a new branch and did a make clean + make all. Then I did swstarthbase. Hbase comes
up successfully. When I do an sqstart however, it hangs at 5 processes and never comes up.
An sqps command fails with:

[birdsall@edev05 trafodion]$ sqps
2019-09-11 23:47:54,, FATAL, TRAFCONFIG,,, PIN: 17917,,,, TID: 17917, Message ID: 101091501,
[CClusterConfig::CClusterConfig], Environment variable TRAF_CLUSTER_ID is undefined, exiting!

So I did a pkillall.

I then did an sqgen, followed by another attempt at sqstart. It still hangs at 5 processes.
I noticed that sqgen did not recreate ms.env, which is where environment variables are defined.
So I tried deleting it, and doing sqgen + sqstart again. Didn't help, same hang.

I noticed something else. When running sqgen, I see:

Can't open /mnt2/birdsall/trafodion/core/sqf/sql/local_hadoop/traf_conf/sqconfig.persist:
No such file or directory at ./ line 606, <> line 12.

So, perhaps I need to blow away my instance and reinstall local_hadoop. So, I tried pkillall
+ git clean -fxd + make all + install_local_hadoop + install_traf_components + sqgen + sqstart.
That's in progress now; will let you know how it turns out.

So this e-mail is just a heads-up that this particular change seems to require a fresh install.

I notice that Jenkins Trafodion tests are running fine, so clean installs should work.


View raw message