uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Lally" <ala...@alum.rpi.edu>
Subject Re: Glossary Definitions for UIMA, Apache UIMA
Date Fri, 02 Feb 2007 19:23:55 GMT
On 2/2/07, Marshall Schor <msa@schor.com> wrote:
> > Should the following two terms be renamed to Apache UIMA Java
> > Framework and Apache UIMA SDK?  And should there be a definition for
> > "Apache UIMA" without the "SDK" part - in which case what is the
> > difference, Apache UIMA is the project, and the SDK is the artifact we
> > produce?
> Hmmm - not sure what the "following 2 terms" are?

I just meant "UIMA Java Framework" renamed to "Apache UIMA Java
Framework" and "UIMA SDK" renamed to "Apache UIMA SDK".  So my
suggested definitions would look sometihng like:

 UIMA: UIMA is an acronym that stands for Unstructured Information
 Management Architecture; it is a software architecture which
 specifies component interfaces, design patterns and development
 roles for creating, describing, discovering, composing and deploying
 multi-modal analysis capabilities.  The UIMA specification is being developed
 by a technical committee at OASIS (hyperlink here).

 Apache UIMA Java Framework:
 A Java-based implementation of the UIMA architecture, developed by
 the Apache UIMA Project. It provides
 a run-time environment in which developers can plug in and run
 their UIMA component implementations and with which they can
 build and deploy UIM applications.

 Apache UIMA Software Development Kit (SDK):
 The SDK includes the framework plus additional components such
 as tooling and examples. Some of the tooling is Eclipse-based

> I think that some UIMA terms should start with UIMA so people find them :-).
OK, but which terms?  Do you want to keep UIMA Java Framework as a
term?  This just seems strange to me, that we wouldn't use the Apache
name to refer to it.

> I would drop the UIMA SDK as a term.
I'm surprised that "SDK" was deleted elsewhere.  The thing we
distribute is still an SDK, I thought.

So you're suggesting that the term "Apache UIMA" means what we used to
call the SDK, and you'd add a new term "Apache UIMA Project" to refer
to the project?


View raw message