uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <uima-...@incubator.apache.org>
Subject [jira] Commented: (UIMA-400) Fix Eclipse plugin
Date Wed, 09 May 2007 20:28:15 GMT

    [ https://issues.apache.org/jira/browse/UIMA-400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12494566
] 

Marshall Schor commented on UIMA-400:
-------------------------------------

We have (had) a goal of making the plugin work in both Eclipse 3.1 and 3.2.  (You might be
surprised how slowly people migrate) - which is why there are duplicates in the plugin in
some cases.  Do you have any suggestions of how to do this better?   

Re: things in manifest, not in plugin and vice-versa, good points - should be fixed.

> Fix Eclipse plugin
> ------------------
>
>                 Key: UIMA-400
>                 URL: https://issues.apache.org/jira/browse/UIMA-400
>             Project: UIMA
>          Issue Type: Bug
>          Components: Eclipse plugins
>    Affects Versions: 2.1
>            Reporter: Mikhail Sogrin
>            Priority: Minor
>
> Manifest for org.apache.uima.runtime plugin in UIMA 2.1 release is not correct:
> - lib/uima-jcas-builtin-types.jar is listed in manifest, but not present in plugin.
> - uima-document-annotation.jar is in distribution, but not in plugin.
> - Exported packages are listed twice, with Export-Package and with Provide-Package. But
Provide-Package has been deprecated since Eclipse 3.1.
> - Exported package org.apache.uima.tttypesystem does not exist in plugin, was removed
in UIMA-64.
> - "Eclipse-BuddyPolicy: registered" is written twice.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message