uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Lally" <ala...@alum.rpi.edu>
Subject Re: Can't get MeetingFinderCPE_Managed_Unix.xml to work - can someone else try it?
Date Wed, 05 Dec 2007 20:29:40 GMT
On Dec 5, 2007 1:21 PM, Eddie Epstein <eaepstein@gmail.com> wrote:
> There was a discussion about this a few weeks ago. Here is part of my reply:
>
> When I did this on Windows it worked fine, but on Linux it hung because the
> deployed service didn't have a proper environment. In order to get it
> working on Linux, I added a PATH environment for the new process in the
> descriptor, e.g.
>
>             <runInSeparateProcess>
>                 <exec dir="." executable="java">
>                                         <env key="PATH"
>
> value="/myPathTo/jdk1.5.0/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/eddie/apache-uima/bin"/>
>
<snip/>

OK, when I added the PATH to the jre, it worked - thanks.  But why
isn't the environment inherited from the parent process?

-Adam

Mime
View raw message