uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eddie Epstein" <eaepst...@gmail.com>
Subject Re: Can't get MeetingFinderCPE_Managed_Unix.xml to work - can someone else try it?
Date Wed, 05 Dec 2007 18:21:43 GMT
There was a discussion about this a few weeks ago. Here is part of my reply:

When I did this on Windows it worked fine, but on Linux it hung because the
deployed service didn't have a proper environment. In order to get it
working on Linux, I added a PATH environment for the new process in the
descriptor, e.g.

            <runInSeparateProcess>
                <exec dir="." executable="java">
                                        <env key="PATH"

value="/myPathTo/jdk1.5.0/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/eddie/apache-uima/bin"/>

                    <env key="CLASSPATH"
                        value="src:/home/eddie/apache-uima/lib/uima-
core.jar:/home/eddie/apache-uima/lib/uima-cpe.jar:/home/eddie/apache-uima/lib/uima-examples.jar:/home/eddie/apache-uima/lib/uima-adapter-vinci.jar:/home/eddie/apache-uima/lib/jVinci.jar"/>
                    <arg>-DLOG=service.log</arg>
                    <arg>
org.apache.uima.adapter.vinci.VinciAnalysisEngineService_impl</arg>
                    <arg>${descriptor}</arg>
                </exec>
            </runInSeparateProcess>

Eddie

On Dec 5, 2007 11:37 AM, Adam Lally <alally@alum.rpi.edu> wrote:

> There seems to be something wrong with CPE managed (aka "local") mode
> on Linux.  I haven't been able to get even the example that ships with
> UIMA to work.
>
> I tried a few different Linux machines.  One one I get an error
> because ksh is not installed - opened a JIRA for that.  On two others,
> which do have ksh, it just hangs.
>
> Can someone else give this a try, just to make sure I'm not doing
> something wrong?  I just installed the uima driver, ran
> adjustExamplePaths, and from the examples directory executed runCPE.sh
>
> descriptors/collection_processing_engine/MeetingFinderCPE_Managed_Unix.xml.
>
> Thanks,
> -Adam
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message