uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Baessler <...@michael-baessler.de>
Subject Re: Cas Editor build script
Date Tue, 06 May 2008 08:48:07 GMT
Now the build works fine for me :-) I also successfully verified the build when using the generated
source package.

Some recommendations from my side:

- add some Apache license header to the release notes (the Incubator ask us to do this for
the next
  release)
- rename the release from 2.2.2CE to just 2.2.2 in the release notes

- the "Cas Editor.ini" file and "configuration/config.ini" file does not have a license header,
are
  these generated files?

- the first image in the HTML documentation is very small, is this related to the PDF?

- The NOTICE file has "Copyright 2006, 2007 The Apache Software Foundation" but I think it
should be
  "Copyright 2006, 2008 The Apache Software Foundation"

- when packaging the source jar, I prefer to add a root folder to the zip that contains the
content.

-- Michael

Jörn Kottmann wrote:
> Hello,
> 
> sorry it took me a while to get to this, but I think I have finally
> solved the issue.
> 
> On my machine is also a build.properties file which is necessary for the
> build.
> I did not noticed that is was not checked-in because it is ignored by svn.
> Now it should build without problems.
> 
> Sorry,
> Jörn
> 
> On Apr 23, 2008, at 12:06 PM, Thilo Goetz wrote:
> 
>> Michael Baessler wrote:
>>> Jörn Kottmann wrote:
>>>> On Apr 23, 2008, at 9:34 AM, Michael Baessler wrote:
>> [...]
>>>>> Sorry I'm still not able to build the CasEditor release.
>>>>> I used the eclipse 3.3.2 version with EMF 2.3.2, delta package 3.3.2
>>>>> and the
>>>>> UIMA plulgins version 2.2.2. I got no build errors, but the CasEditor
>>>>> plugin jar is not created.
>>>>> I also still see the source code in the binary package.
>>>>> Not sure what is wrong on my machine. Maybe someone else can try to
>>>>> build and check if it works.
>>
>> I tried this, too, and get the same results as Michael.  Also windows.
>>
>>>> I tested this with mac os and ubuntu linux. I guess you use windows. I
>>>> will test it too
>>>> on windows tonight or tomorrow night. Maybe there lies the problem.
>>> Yes, I did my tests on windows.
>>> -- Michael
> 


Mime
View raw message