uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <uima-...@incubator.apache.org>
Subject [jira] Reopened: (UIMA-1054) Correct some version dependency levels in uima-as build / poms
Date Mon, 09 Jun 2008 19:18:45 GMT

     [ https://issues.apache.org/jira/browse/UIMA-1054?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Marshall Schor reopened UIMA-1054:
----------------------------------


Testing reveals that log4j as 1.2.12 level is needed for UIMA-AS.  Change the POMs to require
this level.  Note that the base UIMA has a compile dependency for log4j a 1.2.8.  This should
be OK because 1.2.12 seems to be a superset of 1.2.8.

> Correct some version dependency levels in uima-as build / poms
> --------------------------------------------------------------
>
>                 Key: UIMA-1054
>                 URL: https://issues.apache.org/jira/browse/UIMA-1054
>             Project: UIMA
>          Issue Type: Improvement
>          Components: Async Scaleout
>            Reporter: Marshall Schor
>            Assignee: Marshall Schor
>            Priority: Minor
>             Fix For: 2.2.2AS
>
>
> Scanning the dependency tree produced with mvn dependency:tree revealed some incorrect
version dependency levels.   While these probably do not affect anything (unless the APIs
changed with release levels in a way that would affect our code), it would be good to be consistent
between the levels in the POM used for compiling and the levels included in the bin distribution.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message