uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ahmed Abdeen(Home)" <ahmed.elma...@gmail.com>
Subject Re: SaxParserException
Date Fri, 06 Jun 2008 13:59:44 GMT
For some reasons Mac OS X put a .DS_Store file in the data directory. I have
no idea why it did that. The worst part was that this file is hidden and  it
made the problem much more complicated. I removed the file using a shell
command and now it works just fine.
Speaking of developing your own applications, where to start? The
ExampleApplication in the uimaj-examples isn't working even though I am
passing valid parameters.
Thank you!
Ahmed

On Fri, Jun 6, 2008 at 4:03 AM, Thilo Goetz <twgoetz@gmx.de> wrote:

> Marshall Schor wrote:
>
>> Ahmed Abdeen(Home) wrote:
>>
>>> Hello UIMA Developers,I am getting the following error when I run the
>>> UIMA
>>> Document Analyzer.
>>> However, If I use the interactive mode it works fine. I can't specify
>>> what
>>> is the source file of this issue. I would appreciate any help.
>>> Thanks,
>>> Ahmed
>>>
>>>
>> Please see
>> http://incubator.apache.org/uima/downloads/releaseDocs/2.2.2-incubating/docs/html/tutorials_and_users_guides/tutorials_and_users_guides.html#ugr.tug.xmi_emf.xml_character_issues
>>
>> It appears that some String data which is being serialized has invalid
>> character codes in it (from an XML viewpoint) - namely a x'00'. There are
>> several things you can do.
>>
>
> Please note that 0x0 is not just invalid XML, it's also invalid Unicode.
> This sort of thing often happens when you're reading in a file with the
> wrong endcoding, say a utf-16 file read in as utf-8.  Or maybe what you're
> reading in isn't a text file at all.
>
> --Thilo
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message