uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörn Kottmann (JIRA) <uima-...@incubator.apache.org>
Subject [jira] Updated: (UIMA-513) jcasgen_merge script fails with Eclipse 3.3 due to repackaging done by Eclipse
Date Thu, 02 Jul 2009 15:29:47 GMT

     [ https://issues.apache.org/jira/browse/UIMA-513?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jörn Kottmann updated UIMA-513:
-------------------------------

    Affects Version/s: 2.3
                       2.2.1
                       2.2.2

The issue is still open, sure it also applies to the current 3.4 and 3.5 versions of eclipse.

Here is the stack trace on startup with eclipse 3.4:
Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/core/launcher/Main
Caused by: java.lang.ClassNotFoundException: org.eclipse.core.launcher.Main
	at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
Could not find the main class: org.eclipse.core.launcher.Main.  Program will exit.

> jcasgen_merge script fails with Eclipse 3.3 due to repackaging done by Eclipse
> ------------------------------------------------------------------------------
>
>                 Key: UIMA-513
>                 URL: https://issues.apache.org/jira/browse/UIMA-513
>             Project: UIMA
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 2.1, 2.2, 2.2.1, 2.2.2, 2.3
>            Reporter: Marshall Schor
>            Priority: Minor
>
> jcasgen_merge script runs Eclipse in "headless" mode.  The method of starting eclipse
changed in Eclipse 3.3, and the previous method which depends on startup.jar doesn't work
(there is no longer a startup.jar).  See the Eclipse help topic "Incompatibilities between
Eclipse 3.2 and 3.3".  Workaround is to use Eclipse 3.2 for this operation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message