uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörn Kottmann <kottm...@gmail.com>
Subject Re: maven build problem
Date Fri, 03 Jul 2009 08:00:52 GMT
Marshall Schor wrote:
> Jörn Kottmann wrote:
>   
>> Marshall Schor wrote:
>>     
>>> Trying to build uimaj - I get this build error on the Cas Editor
>>> project:
>>>
>>> Couldn't find a version in [3.2.1-v3235e, 3.3.0-v3345b, 3.3.0-v3346] to
>>> match range [3.3.0,4.0.0)
>>>   org.eclipse:swt:jar:null
>>>
>>> from the specified remote repositories:
>>>   central (http://repo1.maven.org/maven2),
>>>   ApacheIncubatorRepository
>>> (http://people.apache.org/repo/m2-incubating-repository),
>>>   eclipsePlugins (http://repo2.maven.org/eclipse)
>>>
>>> Path to dependency:
>>>         1)
>>> org.apache.uima:uimaj-ep-cas-editor:bundle:2.3.0.incubating-SNAPSHOT
>>>         2) org.eclipse:ui:jar:3.3.0-I20070614-0800
>>>
>>> Any ideas?  It seems others have had success in building this.  Is there
>>> another Eclipse plug-in repository that I need to be using?
>>>   
>>>       
>> I have seen a similar error a while back when I set up the project.
>> After some investigation I assumed that something with my local maven
>> repo could be wrong and deleted it. The error vanished after maven
>> download
>> all the dependencies again.
>>     
> Thanks, Jörn.  I deleted the org.eclipse.*  part of my local repository,
> and tried again - this time it failed (before it got to the swt.jar) here:
>
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
>
> Couldn't find a version in [1.0.0-v20070423, 1.0.0-v20070606] to match
> range [1.0.0,2.0.0)
>   org.eclipse.equinox:app:jar:null
>
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   ApacheIncubatorRepository
> (http://people.apache.org/repo/m2-incubating-repository),
>   eclipsePlugins (http://repo2.maven.org/eclipse)
>
> Path to dependency:
>         1)
> org.apache.uima:uimaj-ep-cas-editor:bundle:2.3.0.incubating-SNAPSHOT
>         2) org.eclipse.core:runtime:jar:3.3.100-v20070530
>
> Any other suggestions appreciated :-)
>
> Jörn, could you say what repositories you are using to locate the
> Eclipse maven components?  Maybe I need to point to another maven repo
> for these?
>   
Everything I use is listed in the cas editor pom.xml, I did
not deploy something manually to my repository.

I also deleted the org.eclipse.* folder in my local repo
and then maven downloaded everything again and the
build finished successfully.

Jörn

Mime
View raw message