uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Building the eclipse update site
Date Mon, 06 Jul 2009 15:02:20 GMT
Next issue:

There is a new feature for 2.3.0, the caseditor.  In the current build
approach, each feature needs a separate "feature" project (Eclipse likes
this organization).  There was no uimaj-eclipse-feature-caseditor
project, so I made one :-) and will check it in shortly.

Meanwhile, there's some information I need to properly set up this
project.  Feature projects have a <requires> element that enables
Eclipse to find and install other plugins this one depends on.

The stanza is:

   <requires>
      <import plugin="org.apache.uima.runtime" version="2.3.0"
match="greaterOrEqual"/>
   </requires>

I took a guess that this plugin requires the runtime plugin.  Is that
correct? Does it require any others?

-Marshall

Mime
View raw message