uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thilo Goetz <twgo...@gmx.de>
Subject Re: Building the eclipse update site
Date Thu, 16 Jul 2009 12:16:23 GMT
Marshall Schor wrote:
> I don't believe the UIMA-AS target is called, unless you call it
> explicitly.  Can you say a bit more why you needed to remove it?

True.  I meant this:

  <target name="build-features" depends="init">
    <makeFeatureJar project-name="uimaj-eclipse-feature-deployeditor"
                    org-name="org.apache.uima.deployeditor"
                    version="2.3.0.incubating-SNAPSHOT"/>
	<makeFeatureJar project-name="uimaj-eclipse-feature-runtime"
                    org-name="org.apache.uima.runtime"
                    version="2.3.0.incubating-SNAPSHOT"/>
    <makeFeatureJar project-name="uimaj-eclipse-feature-tools"
                    org-name="org.apache.uima.tools"
                    version="2.3.0.incubating-SNAPSHOT"/>
  </target>	

The uimaj-eclipse-feature-deployeditor is not there, so the
build-features target fails.

--Thilo

> 
> -Marshall
> 
> Thilo Goetz wrote:
>> Marshall Schor wrote:
>>   
>>> At this point, the build procedure is:
>>>
>>> 1) run the build.xml in the uimaj-eclipse-update-site project with the
>>> target set to build-features. You can do this in Eclipse by right
>>> clicking the build.xml file and picking Run-As Ant-build ... 
>>>
>>> 2) copy the features built here into the same project's top level
>>> features folder
>>>
>>> 3) run the build.xml with the "all" target to build the updatesite
>>>
>>> The reason for this convolution: as I recall, this was done to provide
>>> some committer-intentional action when putting things into the top level
>>> features folder - things put there should be release-approved things
>>> that have been voted out (of course, excepting all this "testing"). 
>>> This I think is why we want a better build method that builds the
>>> feature jars - so they can be part of the set of files reviewed and
>>> voted on for the release.
>>>
>>> Still not working (for reasons I have no idea) - the update site seems
>>> to have the cas editor jar, but there is no plugin installed for it.
>>>
>>> It would be good to have another pair of eyes look at this - maybe
>>> there's some misspelling somewhere...
>>>
>>> -Marshall
>>>
>>>     
>> I was able to successfully build the update site and install
>> into Eclipse 3.5.  I tested the CDE and JCasGen, seems to work
>> fine.  Joern, what's a good way to quickly test the CAS Editor?
>>
>> To make this work, I had to do the following:
>>
>> - Manually copy the CAS Editor plugin jar from where it's built
>>   to the update site's plugin directory.  All other plugin jars
>>   are copied there automatically.
>>
>> - Remove the UIMA-AS target.
>>
>> After that it worked like a charm.
>>
>> --Thilo
>>
>>
>>   

Mime
View raw message