uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Burn Lewis <burnle...@gmail.com>
Subject Re: [jira] Commented: (UIMA-1647) Scripts fail to call runUimaClass.sh
Date Tue, 03 Nov 2009 04:55:06 GMT
Marshall,

Since we don't set any variables before calling runUimaClass I don't think
we need the "." --- all that matters is we get the environment and "sh" or
no prefix will do that.

-Burn.

On Mon, Nov 2, 2009 at 6:00 PM, Marshall Schor (JIRA) <
uima-dev@incubator.apache.org> wrote:

>
>    [
> https://issues.apache.org/jira/browse/UIMA-1647?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12772713#action_12772713]
>
> Marshall Schor commented on UIMA-1647:
> --------------------------------------
>
> I did some testing on linux - and found that using the "dot" command seems
> to work properly - any parameters passed on the command line starting with
> the "." are delivered to the inner script correctly.  Also, variables set
> (but not exported) I believe get delivered (by definition - that's what the
> dot does differently from starting a new shell).
>
> I am changing
>
> . runUimaClass.sh .....
>
> to
>
> . "$UIMA_HOME/bin/runUimaClass.sh" ....
>
> which I think will fix the problems reported above, and have some scripts
> which set (but do not export) variables have those variables "visible" to
> the runUimaClass script.
>
> Thanks for offering to do testing - I'll certainly take you up on that :-)
>
> > Scripts fail to call runUimaClass.sh
> > -------------------------------------
> >
> >                 Key: UIMA-1647
> >                 URL: https://issues.apache.org/jira/browse/UIMA-1647
> >             Project: UIMA
> >          Issue Type: Bug
> >          Components: Async Scaleout
> >    Affects Versions: 2.3AS
> >         Environment: Ubuntu Server 8.10, Java 1.6
> >            Reporter: Jörn Kottmann
> >            Assignee: Marshall Schor
> >            Priority: Blocker
> >             Fix For: 2.3AS
> >
> >
> > Executing deployAsyncService.sh fails with the following error message:
> > .: 28: runUimaClass.sh: not found
> > deployAsyncService.sh calls runUimaClass.sh with ". runUimaClass.sh ...",
> > in an older version this script called setUimaClassPath.sh, but that was
> > done with the absolute path:
> > . "$UIMA_HOME/bin/setUimaClassPath.sh"
> > I suggest that we change all our .sh scripts to use the absolute path
> like
> > it was done before for at least the deployAsyncService.sh script.
>
> --
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message