uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Building uima-as fails
Date Thu, 02 Dec 2010 14:46:51 GMT


On 12/2/2010 9:10 AM, Jörn Kottmann wrote:
> Thanks, now I am able to build it.
> I believe my mistake was that I went to the aggregate folders
> in uimaj and uima-as.
>
> When following the correct way as Marshall described it, the build
> runs trough.

I think that the difficulty was that the local parent pom needed to be checked
out of SVN and built...

The other stuff I said about uimaj dependencies etc., was only for building the
binary distribution (uima-as-distr), which is a submodule of the uima-as project.

Once the parent pom is built, building the aggregate-uima-as should work OK.

-Marshall
>
> Thanks,
> Jörn
>
> On 12/2/10 2:47 PM, Marshall Schor wrote:
>> Looking at the error message
>>
>> [ERROR] Failed to execute goal on project uimaj-as-core:
>>
>> Could not resolve dependencies for project
>> org.apache.uima:uimaj-as-core:jar:2.3.1-SNAPSHOT:
>>
>> Failed to collect dependencies for
>>      [commons-pool:commons-pool:jar:1.2 (compile),
>>      org.apache.uima:uimaj-core:jar:2.3.1-SNAPSHOT (compile),
>>      org.springframework:spring:jar:2.0.6 (compile)]:
>>
>> Failed to read artifact descriptor for
>> org.apache.uima:uimaj-core:jar:2.3.1-SNAPSHOT:
>>
>> Failure to find org.apache.uima:uimaj-parent:pom:2.3.1-SNAPSHOT in
>> http://repository.apache.org/snapshots was cached in the local repository,
>> resolution will not be reattempted until the update interval of
>> apache.snapshots.plugins has elapsed or updates are forced
>>
>> ------
>>
>> The build for uima-as was changed recently, in a couple of ways.
>>
>> 1) A new uima-as-parent pom was added, and other projects in uima-as now use
>> this as their project-wide parent.  That parent, in turn, has the main uima
>> parent-pom as its parent.  To pick up this change, you need to update from trunk
>> the entire uima-as project, and then build the parent either by cd
>> uima-as-parent and mvn install, or by cd to uima-as and doing mvn install
>> (uima-as is an aggregator for uima-as-distr and uima-as-parent).  But see below.
>>
>> 2) uima-as-distr was changed to incorporate base uimaj - it does this by
>> depending on the artifacts built by uimaj-distr (particularly, the binary
>> distribution zip object).
>>
>> The error messages seem to indicate that maybe the uima-as svn checkout isn't up
>> to date with these changes; or that uimaj base distribution hasn't been built
>> using mvn install (I checked and I see that the uimaj-distr build artifact
>> hasn't been deployed to the snapshot repo - which I'll do shortly, which will
>> avoid needing to first build the uimaj base distribution.)
>>
>> To build the uimaj sdk that uima-as now depends on, check out or update to head
>> your uimaj/trunk, cd to uimaj, and do mvn install (or for faster building: mvn
>> install -Dmaven.test.skip ).
>>
>> NOTE: this need to build uimaj sdk ahead of uima-as will come and go - it will
>> depend on which version (of uimaj sdk) uima-as depends on.  If it depends on the
>> current -SNAPSHOT version (like it does now), then you'll need to do this, or
>> hope that there's a snapshot in the snapshot repo.  When it's time to release
>> uima-as, before releasing, we'll change this dependency to a "released" version
>> of uimaj sdk, and then it will be found in Maven Central
>>
>> ----------
>>
>> Bottom line: to get going:
>>
>> 1) checkout / update to head uimaj sdk, cd to uimaj, and mvn install
>> 2) update to head uima-as, cd to uima-as, and mvn install
>>
>> Hope this fixes things :-)  -Marshall
>>
>> -Marshall
>>
>> On 12/1/2010 7:25 PM, Jörn Kottmann wrote:
>>> On 12/2/10 1:10 AM, Burn Lewis wrote:
>>>> I ran mvn install from the uima-as directory successfully.
>>>>
>>>> ~Burn
>>>>
>>> Tried it again, but error message stays the same, maybe you have
>>> this parent pom in your local repo?
>>> I did it after wiping the uima dir in my local repo, and on a fresh
>>> machine.
>>>
>>> Jörn
>>>
>>>
>
>
>

Mime
View raw message