uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörn Kottmann <kottm...@gmail.com>
Subject Re: Hudson CI build for UIMA-SDK not quite working - how to debug?
Date Wed, 23 Feb 2011 22:39:21 GMT
An option would be to bind the build to the ubuntu build servers,
should we try that? Anyway it would be nice if the build could
run on all platforms.

Jörn

On 2/23/11 11:33 PM, Marshall Schor wrote:
> Some further analysis:
>
> With respect to this issue (having docbook pick up the cross-ref info for other
> books),
>
> a) This works fine on Windows, and on Mac, but fails on the build machine Hudson
> is using (I think solaris).
>
> b) Looking at the "spec" for the failing file url, it is likely:
>
>    file:///c:/blah/blah... on windows and
>    file:////export/home/blah/blah on solaris
>
> Note the extra "/" after file:
>
> The actual string is composed of a literal "file:///" and something that starts
> with
> ${settings.localRepository}.  From other output on the console I can deduce that
> this value starts with a single "/".
>
> The doubling of the // seems to be dropped on the solaris OS, leading to a failure.
>
> For Windows, /// is needed after the file: because the path starts with c:, and
> not a "/".
>
> I'll look into fixing this with profiles...  (ugh). unless others have a better
> idea.
>
> -Marshall
>
> On 2/22/2011 2:29 PM, Marshall Schor wrote:
>> Although it says "success" , in reviewing the console output I see it is failing
>> to acquire the Docbook "database" of links for cross referencing between books.
>>
>> This shows up in the console as lines that look like:
>>
>> [INFO] --- docbkx-maven-plugin:2.0.11:generate-html (html) @ uima-docbook-overview-and-setup
---
>> [INFO] Processing input file: overview_and_setup.xml
>> Recoverable error
>> Failure reading file://export/home/hudson/.m2/repository/org/apache/uima/uima-docbook-olink/1-SNAPSHOT/docbook-olink/htmlsingle/site.xml:
export
>> Recoverable error
>>
>> The docbook build gets a specific zip file that has this in it, and unpacks it into
the local ".m2" repo at the designated spot.
>>
>> The error message is saying this file isn't there.
>>
>> The console log shows the containing zip file isn't being unpacked because it's already
unpacked.
>>
>> The path to the repo seems right, because other console lines say that installs into
the repo are going into
>>
>> "/export/home/hudson/.m2/repository/org/apache/uima/ ..."
>>
>> So, it seems everything is working as expected, except part of the messages say the
zip is already unzipped, and another part of the console log is saying file is missing.
>>
>>
>> To debug further, is it possible to see the files in /export/home/hudson/.m2/repository/org/apache/uima/...
?  or is this repository deleted before every build run?
>>
>> -Marshall
>>
>>
>>


Mime
View raw message