uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Jenkins build failure due to OSGi bundle plugin needing Java 1.6
Date Mon, 01 Aug 2011 20:04:28 GMT
We currently set our build processes to use Java 5.  This insures we don't
accidentally "depend" on a method which is only in Java 6.

The Felix OSGi bundle plugin (version 2.3.5) requires Java 6 - it uses a String
class getBytes(Charset....) method, which was added in Java 6.

We are using version 2.3.5 because it eliminates various spurious warnings, as
compared to earlier levels.

Not sure how to work around this - maybe there's a way to run "forked" in a
different JVM.

-Marshall

Mime
View raw message