uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Jenkins build failure due to OSGi bundle plugin needing Java 1.6
Date Mon, 01 Aug 2011 20:31:38 GMT
Got a reply right away on the Felix users list to the q: if Java 6 requirement
was intentional:

not intentional - https://issues.apache.org/jira/browse/FELIX-3037 - happened when we picked
up the new version of bnd

if you don't need any of the changes in 2.3.5 you can lock down the plugin version to 2.3.4,
which does work with Java 5



I'll try 2.3.4

-Marshall

On 8/1/2011 4:04 PM, Marshall Schor wrote:
> We currently set our build processes to use Java 5.  This insures we don't
> accidentally "depend" on a method which is only in Java 6.
>
> The Felix OSGi bundle plugin (version 2.3.5) requires Java 6 - it uses a String
> class getBytes(Charset....) method, which was added in Java 6.
>
> We are using version 2.3.5 because it eliminates various spurious warnings, as
> compared to earlier levels.
>
> Not sure how to work around this - maybe there's a way to run "forked" in a
> different JVM.
>
> -Marshall
>

Mime
View raw message