uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: [jira] [Commented] (UIMA-2141) Annotations Styles view - filter field
Date Thu, 04 Aug 2011 01:08:27 GMT
Hi Richard,

Do you use m2eclipse? (see http://uima.apache.org/one-time-setup.html  - the
Eclipse part especially)

In my Eclipse 3.6.2, the .classpath for uima-ep-jcasgen looks like:

<?xml version="1.0" encoding="UTF-8"?>
<classpath>
    <classpathentry kind="src" output="target/classes" path="src/main/java"/>
    <classpathentry excluding="**" kind="src" output="target/classes"
path="src/main/resources"/>
    <classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
    <classpathentry kind="con"
path="org.maven.ide.eclipse.MAVEN2_CLASSPATH_CONTAINER"/>
    <classpathentry kind="output" path="target/classes"/>
</classpath>

I'm using the m2eclipse plugin at version 0.12.1.20110112-1712.

What version are you using, and do you have this MAVEN2_CLASSPATH_CONTAINER kind
of classpath entry?

-Marshall

On 8/3/2011 3:59 PM, Richard Eckart de Castilho wrote:
> Hi folks,
>
>>> Thanks Jörn, I'll have a try.
>> Let us know about any problems, so I can help you.
> finally, I found a few minutes to have another stab at UIMA. I have reverted all changes
that I may have had and updated to the latest version from SVN. Everything seems to compile
fine, but I still have 33 plug-in errors in the following projects:
>
> uimaj-ep-cas-editor
> uimaj-ep-configurator
> uimaj-ep-jcasgen
> uimaj-ep-pear-packager
>
> All are of the type "No available bundle exports package 'org.apache.uima...'" - the
packages seems always to be from uimaj-core. 
> Do I get these errors occur because the uimaj-core project has no OSGi metadata?
> I do have the uimaj-ep-runtime 2.3.2.SNAPSHOT plugin installed in my Eclipse. Shouldn't
Eclipse be able to locate the packages exported by that?
>
> Cheers,
>
> Richard
>
> Btw.: I find it interesting that m2eclipse now seems to support Eclipse plugin projects.
When I last tried to mix Maven with RCP quite some time ago and had both the Plug-in Dependencies
Libaray and the Maven Dependencies Library in the classpath, Eclipse kept on complaining about
duplicate classes. This seems to work fine now.
>

Mime
View raw message