uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Klügl <pklu...@uni-wuerzburg.de>
Subject Re: purpose of POM in eclipse-packagings
Date Wed, 19 Dec 2012 14:00:55 GMT
Hi,

On 19.12.2012 14:54, Marshall Schor wrote:
> I notice there's a POM in the eclipse-packagings project, but I didn't see in
> the procedure any step which would have run maven with this POM.  Is it needed?

It is not needed, if the updatesite of the chlid repository extends the 
composite repository. However, if you do not want to build the child 
repository, but only extend the composite one, then you can additionally 
use the pom for that.

Peter


> -Marshall
>
>
> On 11/29/2012 11:31 AM, Peter Klügl wrote:
>> Hi,
>>
>> this vote is about replacing the current update site with a composite
>> repository, which essentially contains the same artifacts as before.
>>
>> We discussed in UIMA-2475 (https://issues.apache.org/jira/browse/UIMA-2475)
>> that the update site of Apache UIMA is not compatible with p2 repositories.
>> This complicates, for example, the development of bundles built with Tycho.
>> The result of the discussion is right now a composite repository, which refers
>> to two update sites. The first one is exactly the currently published update
>> site (legacy) and the second one is a p2 repository (uima-2.4.0) containing
>> the eclipse bundles of the 2.4.0 release. Note that these artifacts are
>> provided twice.
>>
>> The new update site (composite repository) is here:
>> https://svn.apache.org/repos/asf/uima/eclipse-packagings/eclipse-update-site
>>
>> Please vote to approve this release:
>>
>> [ ] +1 Approve the release
>> [ ] -1 Veto the release (please provide specific comments)
>> [ ] 0   Don't care
>>
>> PS: As this is essentially not a new release, I skipped most/all parts
>> mentioned in http://uima.apache.org/release.html
>>
>>


Mime
View raw message