uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-2523) Rename module folders
Date Thu, 13 Dec 2012 16:50:14 GMT

    [ https://issues.apache.org/jira/browse/UIMA-2523?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13531172#comment-13531172
] 

Marshall Schor commented on UIMA-2523:
--------------------------------------

The top level of the unzipped original patch has
   grant-staging
      ...
      pom.xml

The top-level pom has the artifact name (currently) of 
      uimafit-pom

The current top-level folder in SVN is:
      uimaFIT, located here:

  .../sandbox/trunk/uimaFIT

We (by convention) in all of our other projects, name the top level a name which goes with
the overall set of projects making up the item (whose POM has the <modules> specifying
the subprojects that are part of it), so in some sense, uimaFIT or uimafit seems appropriate;
.  That name is already in use, however... :-).

We use xxx-parent for additional levels of common Maven factoring-out / sharing. So, the main
uimaj component has a top-level artifact-id of uimaj, and has <modules> incorporating
the subprojects.  It also has a uimaj-parent, which all the submodules use as its parent,
and which is released together as part of the uimaj release.  It, in turn, inherits from the
common uima super-pom (in build/parent-pom).

This allows changes to be made first within single released things, and then (if more widely
reusable) migrated up to higher levels of super-pom-ness (how's that for a new word).

If you want to follow these conventions, then we can do another Jira renaming:
  top-level artifact    from: uimafit-parent  to: uimafit
  old uimafit artifact  from: uimafit         to: uimafit-core ??? or ???
  new common shared pom stuff:                    uimafit-parent

We have found it much easier to maintain things if the <modules> aggregation is kept
separate from the upwards common sharing done via the parent-pom mechanism.

Depending on what you decide, some renaming of the top level folder (under sandbox/) is needed
to make it match the top level artifact name.  Let me know what you what to do here.  Currently
it is: uimaFIT, artifact-id is uimafit-parent
                
> Rename module folders
> ---------------------
>
>                 Key: UIMA-2523
>                 URL: https://issues.apache.org/jira/browse/UIMA-2523
>             Project: UIMA
>          Issue Type: Bug
>          Components: Sandbox-uimafit
>            Reporter: Richard Eckart de Castilho
>            Priority: Minor
>
> The module folders in uimaFIT do not match the artifactIds. The module folders use the
capitalization "uimaFIT" while the artifactIds use "uimafit".
> The folders should be renamed to use the lower-case variant and the module section of
the aggregator POM should be adjusted accordingly.
> The currently different capitalization might cause problems in Eclipse when patches are
applied, as Eclipse uses the artifactId as the project name and consequently workspace locations
have different names than their respective directories on the file system (cf. UIMA-2522).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message