uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Eckart de Castilho (JIRA)" <...@uima.apache.org>
Subject [jira] [Updated] (UIMA-2531) DLTK dependency cannot be resolved
Date Mon, 17 Dec 2012 15:10:13 GMT

     [ https://issues.apache.org/jira/browse/UIMA-2531?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard Eckart de Castilho updated UIMA-2531:
---------------------------------------------

    Description: 
It seems that not all dependencies can be resolved when trying to build TextMarker with a
vanilla Maven:

{quote}
[ERROR] Failed to execute goal on project uimaj-ep-textmarker-ide: Could not resolve dependencies
for project org.apache.uima:uimaj-ep-textmarker-ide:jar:2.0.0-SNAPSHOT: Failed to collect
dependencies for [org.eclipse.dltk:core:jar:[3.0.1,4.0.0) (provided), org.eclipse.dltk:ui:jar:[3.0.1,4.0.0)
(provided), org.eclipse.dltk:launching:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk.validators:core:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk.validators:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:console:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk.console:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:debug:jar:[3.0.1,4.0.0)
(provided), org.eclipse.dltk.debug:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:formatter:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk:testing:jar:[3.0.0,4.0.0) (provided), org.eclipse.core:runtime:jar:[3.3.0,4.0.0)
(provided), org.eclipse.core:jobs:jar:[3.3.0,4.0.0) (provided), org.eclipse.core:resources:jar:[3.3.0,4.0.0)
(provided), org.eclipse:search:jar:[3.2.0,4.0.0) (provided), org.eclipse:ui:jar:[3.3.0,4.0.0)
(provided), org.eclipse.swt:org.eclipse.swt.win32.win32.x86:jar:[3.2.0,4.0.0) (provided),
org.eclipse.ui:ide:jar:[3.3.0,4.0.0) (provided), org.eclipse.ui:views:jar:[3.3.0,4.0.0) (provided),
org.eclipse.ui:console:jar:[3.2.0,4.0.0) (provided), org.eclipse.ui.workbench:texteditor:jar:[3.3.0,4.0.0)
(provided), org.eclipse.jface:text:jar:[3.3.0,4.0.0) (provided), org.eclipse.core:variables:jar:[3.2.0,4.0.0)
(provided), org.eclipse.jdt:launching:jar:[3.3.0,4.0.0) (provided), org.eclipse.jdt:core:jar:[3.3.0,4.0.0)
(provided), org.eclipse.jdt.debug:ui:jar:[3.2.0,4.0.0) (provided), org.eclipse.core:contenttype:jar:[3.4.0,4.0.0)
(provided), org.eclipse.equinox:preferences:jar:[3.3.0,4.0.0) (provided), org.eclipse.equinox:app:jar:[1.3.0,2.0.0)
(provided), org.eclipse.emf.ecore:xmi:jar:[2.7.0,3.0.0) (provided), org.apache.uima:uimaj-textmarker:jar:2.0.0-SNAPSHOT
(compile)]: No versions available for org.eclipse.dltk:core:jar:[3.0.1,4.0.0) within specified
range -> [Help 1]
{quote}

  was:
It seems that not all dependencies can be resolved when trying to build TextMarker with a
vanilla Maven:

{noformat}
[ERROR] Failed to execute goal on project uimaj-ep-textmarker-ide: Could not resolve dependencies
for project org.apache.uima:uimaj-ep-textmarker-ide:jar:2.0.0-SNAPSHOT: Failed to collect
dependencies for [org.eclipse.dltk:core:jar:[3.0.1,4.0.0) (provided), org.eclipse.dltk:ui:jar:[3.0.1,4.0.0)
(provided), org.eclipse.dltk:launching:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk.validators:core:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk.validators:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:console:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk.console:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:debug:jar:[3.0.1,4.0.0)
(provided), org.eclipse.dltk.debug:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:formatter:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk:testing:jar:[3.0.0,4.0.0) (provided), org.eclipse.core:runtime:jar:[3.3.0,4.0.0)
(provided), org.eclipse.core:jobs:jar:[3.3.0,4.0.0) (provided), org.eclipse.core:resources:jar:[3.3.0,4.0.0)
(provided), org.eclipse:search:jar:[3.2.0,4.0.0) (provided), org.eclipse:ui:jar:[3.3.0,4.0.0)
(provided), org.eclipse.swt:org.eclipse.swt.win32.win32.x86:jar:[3.2.0,4.0.0) (provided),
org.eclipse.ui:ide:jar:[3.3.0,4.0.0) (provided), org.eclipse.ui:views:jar:[3.3.0,4.0.0) (provided),
org.eclipse.ui:console:jar:[3.2.0,4.0.0) (provided), org.eclipse.ui.workbench:texteditor:jar:[3.3.0,4.0.0)
(provided), org.eclipse.jface:text:jar:[3.3.0,4.0.0) (provided), org.eclipse.core:variables:jar:[3.2.0,4.0.0)
(provided), org.eclipse.jdt:launching:jar:[3.3.0,4.0.0) (provided), org.eclipse.jdt:core:jar:[3.3.0,4.0.0)
(provided), org.eclipse.jdt.debug:ui:jar:[3.2.0,4.0.0) (provided), org.eclipse.core:contenttype:jar:[3.4.0,4.0.0)
(provided), org.eclipse.equinox:preferences:jar:[3.3.0,4.0.0) (provided), org.eclipse.equinox:app:jar:[1.3.0,2.0.0)
(provided), org.eclipse.emf.ecore:xmi:jar:[2.7.0,3.0.0) (provided), org.apache.uima:uimaj-textmarker:jar:2.0.0-SNAPSHOT
(compile)]: No versions available for org.eclipse.dltk:core:jar:[3.0.1,4.0.0) within specified
range -> [Help 1]
{noformat}

    
> DLTK dependency cannot be resolved
> ----------------------------------
>
>                 Key: UIMA-2531
>                 URL: https://issues.apache.org/jira/browse/UIMA-2531
>             Project: UIMA
>          Issue Type: Bug
>          Components: TextMarker
>            Reporter: Richard Eckart de Castilho
>
> It seems that not all dependencies can be resolved when trying to build TextMarker with
a vanilla Maven:
> {quote}
> [ERROR] Failed to execute goal on project uimaj-ep-textmarker-ide: Could not resolve
dependencies for project org.apache.uima:uimaj-ep-textmarker-ide:jar:2.0.0-SNAPSHOT: Failed
to collect dependencies for [org.eclipse.dltk:core:jar:[3.0.1,4.0.0) (provided), org.eclipse.dltk:ui:jar:[3.0.1,4.0.0)
(provided), org.eclipse.dltk:launching:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk.validators:core:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk.validators:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:console:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk.console:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:debug:jar:[3.0.1,4.0.0)
(provided), org.eclipse.dltk.debug:ui:jar:[3.0.0,4.0.0) (provided), org.eclipse.dltk:formatter:jar:[3.0.0,4.0.0)
(provided), org.eclipse.dltk:testing:jar:[3.0.0,4.0.0) (provided), org.eclipse.core:runtime:jar:[3.3.0,4.0.0)
(provided), org.eclipse.core:jobs:jar:[3.3.0,4.0.0) (provided), org.eclipse.core:resources:jar:[3.3.0,4.0.0)
(provided), org.eclipse:search:jar:[3.2.0,4.0.0) (provided), org.eclipse:ui:jar:[3.3.0,4.0.0)
(provided), org.eclipse.swt:org.eclipse.swt.win32.win32.x86:jar:[3.2.0,4.0.0) (provided),
org.eclipse.ui:ide:jar:[3.3.0,4.0.0) (provided), org.eclipse.ui:views:jar:[3.3.0,4.0.0) (provided),
org.eclipse.ui:console:jar:[3.2.0,4.0.0) (provided), org.eclipse.ui.workbench:texteditor:jar:[3.3.0,4.0.0)
(provided), org.eclipse.jface:text:jar:[3.3.0,4.0.0) (provided), org.eclipse.core:variables:jar:[3.2.0,4.0.0)
(provided), org.eclipse.jdt:launching:jar:[3.3.0,4.0.0) (provided), org.eclipse.jdt:core:jar:[3.3.0,4.0.0)
(provided), org.eclipse.jdt.debug:ui:jar:[3.2.0,4.0.0) (provided), org.eclipse.core:contenttype:jar:[3.4.0,4.0.0)
(provided), org.eclipse.equinox:preferences:jar:[3.3.0,4.0.0) (provided), org.eclipse.equinox:app:jar:[1.3.0,2.0.0)
(provided), org.eclipse.emf.ecore:xmi:jar:[2.7.0,3.0.0) (provided), org.apache.uima:uimaj-textmarker:jar:2.0.0-SNAPSHOT
(compile)]: No versions available for org.eclipse.dltk:core:jar:[3.0.1,4.0.0) within specified
range -> [Help 1]
> {quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message