uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Klügl <pklu...@uni-wuerzburg.de>
Subject Re: Questions about TextMarker release
Date Tue, 22 Jan 2013 10:02:58 GMT
On 21.01.2013 22:27, Marshall Schor wrote:
> One more strange thing to check:
>
> SVN changed its working directory "metadata" format going from 1.6 to 1.7
> (client versions)
>
> If you accidentally have two client levels (one for 1.6 and one for 1.7) on your
> checkout machine, and Eclipse uses one, but maven uses another, then that could
> be trouble.
>
> Eclipse uses the one based on the level of the subclipse download you install.
> Maven uses (I think) the one installed as a command line module.
>
> You can see the version on the command line module by doing:
>
> svn --version
>
> You can see the version in Eclipse by doing menu -> help -> install new software
> -> what's already installed and then looking for Subclipse.  If it says 1.6.xx,
> then it for Subversion 1.6.x  If it says 1.8.x, it's for Subversion 1.7.x

The svn versions I am using:

command line: svn, Version 1.7.8-SlikSvn-1.7.8-X64 (SlikSvn/1.7.8) X64
eclipse plugin: Subclipse (Required)    1.8.16 
org.tigris.subversion.subclipse.feature.group    tigris.org

The eclipse plugin offers me the option to upgrade the projects... I 
gonna do that and then try to run mvn on command line.

Peter


> -Marshall
> On 1/21/2013 3:07 PM, Peter Klügl wrote:
>> Hi Richard,
>>
>> Am 21.01.2013 20:48, schrieb Richard Eckart de Castilho:
>>> Hi Peter,
>>>
>>> to avoid username/pw on the command line, I had to use a differnent svn
>>> binary. Normally it should be enough to log in on the command line once (e.g.
>>> by issuing a "svn log" command) and let svn cache the credentials.
>>>
>>> But anyway, your error doesn't look like missing credentials (it should say
>>> something along the lines "access denied") it rather looks like a SVN server
>>> glitch - something I get on Google Code every one in a while. Did you try
>>> just calling "mvn release:prepare" again? Maven remembers where the release
>>> process got stuck and will pick up again there. If you need to abort the
>>> release, use "mvn release:rollback".
>> The first try was "mvn -DautoVersionSubmodules release:prepare
>> release:perform" and failed. Then, I executed "mvn release:rollback" and tried
>> only "mvn -DautoVersionSubmodules release:prepare". This also failed, followed
>> by another rollback.
>>
>> I gonna do some internet search about the error message tomorrow . Maybe I
>> find some explanation what might be causing this.
>>
>> Btw, I am doing this in Eclipse with "Maven/run as..." and with an external
>> maven install. Shouldn't be a problem, I think.
>>
>> Peter
>>
>>> Cheers,
>>>
>>> -- Richard
>>>
>>> Am 21.01.2013 um 19:38 schrieb Peter Klügl <pkluegl@uni-wuerzburg.de>:
>>>
>>>> On 17.01.2013 19:08, Richard Eckart de Castilho wrote:
>>>>> Am 17.01.2013 um 15:09 schrieb Marshall Schor <msa@schor.com>:
>>>>>
>>>>>>> If your release fails at some SVN operation like creating the
tag, try
>>>>>>> providing "-Dusername=XXX -Dpassword=YYY" on the command line
with your
>>>>>>> SVN credentials.
>>>>>> I've never had to do this.  I would be careful, in case these are
sent in the
>>>>>> "clear" (I don't know about this).
>>>>> If you local SVN setup is well configured, this should not be required.
>>>>> I've had some issues in the past on OS X with SVN not picking up cached
>>>>> passwords during a Maven release. I didn't read the code, but I expect
the
>>>>> credentials are passed on when Maven calls the external SVN process and
are
>>>>> sent via whatever protocol you use to communicate with the SVN server.
But
>>>>> they do end up in the shell history of course - clearing the command
from
>>>>> there after the process is certainly wise.
>>>>>
>>>>> -- Richard
>>>>>
>>>> Hmm... that probably happened to me now but the error doesn't look like
>>>> missing SVN credentials.
>>>>
>>>> The SVN setup looks fine. Any idea how to avoid "-Dusername=XXX
>>>> -Dpassword=YYY"?
>>>>
>>>> Btw, I wasn't asked yet for the tag (RC1), but I think that will happen
>>>> later, right?
>>>>
>>>> Here's the console:
>>>>
>>>> ...
>>>> [INFO] [INFO] Reactor Summary:
>>>> [INFO] [INFO]
>>>> [INFO] [INFO] Apache UIMA TextMarker: uimaj-textmarker-parent ... SUCCESS
>>>> [33.945s]
>>>> [INFO] [INFO] Apache UIMA TextMarker: uimaj-textmarker .......... SUCCESS
>>>> [25.917s]
>>>> [INFO] [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-engine
>>>> SUCCESS [24.788s]
>>>> [INFO] [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-ide
>>>> SUCCESS [23.878s]
>>>> [INFO] [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-caseditor
>>>> SUCCESS [9.476s]
>>>> [INFO] [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-addons
>>>> SUCCESS [14.046s]
>>>> [INFO] [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-textruler
>>>> SUCCESS [12.535s]
>>>> [INFO] [INFO] Apache UIMA TextMarker Documentation .............. SUCCESS
>>>> [26.484s]
>>>> [INFO] [INFO] Apache UIMA TextMarker Eclipse:
>>>> uimaj-textmarker-eclipse-feature  SUCCESS [7.376s]
>>>> [INFO] [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] [INFO] BUILD SUCCESS
>>>> [INFO] [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] [INFO] Total time: 2:59.468s
>>>> [INFO] [INFO] Finished at: Mon Jan 21 19:24:28 CET 2013
>>>> [INFO] [INFO] Final Memory: 146M/461M
>>>> [INFO] [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] Checking in modified POMs...
>>>> [INFO] Executing: cmd.exe /X /C "svn --non-interactive commit --file
>>>> C:\Users\pkluegl\AppData\Local\Temp\maven-scm-1977004734.commit --targets
>>>> C:\Users\pkluegl\AppData\Local\Temp\maven-scm-2678525437479394015-targets"
>>>> [INFO] Working directory:
>>>> D:\work\workspace-textmarker-build5\uimaj-textmarker-parent
>>>> [INFO] Tagging release with the label uimaj-textmarker-parent-2.0.0...
>>>> [INFO] Executing: cmd.exe /X /C "svn --non-interactive copy --file
>>>> C:\Users\pkluegl\AppData\Local\Temp\maven-scm-343353279.commit --revision
>>>> 1436535 https://svn.apache.org/repos/asf/uima/sandbox/TextMarker/trunk
>>>> https://svn.apache.org/repos/asf/uima/sandbox/TextMarker/tags/uimaj-textmarker-parent-2.0.0"
>>>>
>>>> [INFO] Working directory:
>>>> d:\work\workspace-textmarker-build5\uimaj-textmarker-parent
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Reactor Summary:
>>>> [INFO]
>>>> [INFO] Apache UIMA TextMarker: uimaj-textmarker-parent ... FAILURE [3:16.435s]
>>>> [INFO] Apache UIMA TextMarker: uimaj-textmarker .......... SKIPPED
>>>> [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-engine SKIPPED
>>>> [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-ide SKIPPED
>>>> [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-caseditor  SKIPPED
>>>> [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-addons SKIPPED
>>>> [INFO] Apache UIMA TextMarker Eclipse: uimaj-ep-textmarker-textruler  SKIPPED
>>>> [INFO] Apache UIMA TextMarker Documentation .............. SKIPPED
>>>> [INFO] Apache UIMA TextMarker Eclipse: uimaj-textmarker-eclipse-feature
>>>> SKIPPED
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] BUILD FAILURE
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Total time: 3:18.044s
>>>> [INFO] Finished at: Mon Jan 21 19:24:41 CET 2013
>>>> [INFO] Final Memory: 17M/221M
>>>> [INFO] ------------------------------------------------------------------------
>>>> [ERROR] Failed to execute goal
>>>> org.apache.maven.plugins:maven-release-plugin:2.1:prepare (default-cli) on
>>>> project uimaj-textmarker-parent: Unable to tag SCM
>>>> [ERROR] Provider message:
>>>> [ERROR] The svn tag command failed.
>>>> [ERROR] Command output:
>>>> [ERROR] svn: E160006: No such revision 1436535
>>>> [ERROR] -> [Help 1]
>>>> [ERROR]
>>>> [ERROR] To see the full stack trace of the errors, re-run Maven with the
-e
>>>> switch.
>>>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>>>> [ERROR]
>>>> [ERROR] For more information about the errors and possible solutions, please
>>>> read the following articles:
>>>> [ERROR] [Help 1]
>>>> http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
>>


Mime
View raw message