uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Kl├╝gl <pklu...@uni-wuerzburg.de>
Subject Re: [VOTE] Apache UIMA Ruta 2.0.1 RC2
Date Wed, 08 May 2013 08:40:56 GMT
On 07.05.2013 19:09, Richard Eckart de Castilho wrote:
> Hi,
>
>> Composite repository:
>> https://dist.apache.org/repos/dist/dev/uima/eclipse-update-site
> I just added this to my Eclipse. The version in there is 2.0.1. Several other Eclipse
plugins also have a time-stamp. Would it be useful to use such a time-stamped version (2.0.1.201305071232)?
I imaginge that way it would be easy to upgrade to new RCs and to the final in the end.

Right, that's quite annoying to use always a new eclipse installation to
test an RC.  I must admit that I do not know if our build process allows
qualifiers (as PDE does), but I have the feeling that it cannot be added
without problems. There might be a quick and dirty solution by changing
all version information after the update site was built, but then you
could also just replace the plugins of your eclipse installation (since
they have the same version).

Are there any ideas how to include qualifiers in our build process for
eclipse bundles? We could configure felix to add the qualifier to the
version (or replace SNAPSHOT), but I do not know if it will be resolved.
We could also directly add the timestamp. I suppose I just have to try
it, but I am in favor of doing this after the release.

Best,

Peter


> -- Richard


Mime
View raw message