uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject running the jcasgen-maven-plugin build from Eclipse - requires not using EMBEDDED version of maven
Date Tue, 11 Jun 2013 22:42:12 GMT
I tried the following:

Go to the project in the Eclipse package explorer, right click it and pick
Run-as -> maven install.

The integration test failed with the message:

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-invoker-plugin:1.7:run (integration-test) on
project jcasgen-maven-plugin: Execution integration-test of goal
org.apache.maven.plugins:maven-invoker-plugin:1.7:run failed: ${maven.home} is
not specified as a directory: 'C:\uimaj\jcasgen-maven-plugin\EMBEDDED'. -> [Help 1]

Changing my Eclipse Preferences -> Maven -> Installations to use a non-embedded
version of Maven got around this issue.

-Marshall

Mime
View raw message