uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Resolved] (UIMA-1710) All projects should fail if not compiled with at least maven 2.2.0
Date Thu, 13 Jun 2013 14:26:20 GMT

     [ https://issues.apache.org/jira/browse/UIMA-1710?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Marshall Schor resolved UIMA-1710.
----------------------------------

    Resolution: Fixed

has had maven <prerequisites> set to 3.0 since October, 2010
                
> All projects should fail if not compiled with at least maven 2.2.0
> ------------------------------------------------------------------
>
>                 Key: UIMA-1710
>                 URL: https://issues.apache.org/jira/browse/UIMA-1710
>             Project: UIMA
>          Issue Type: Bug
>          Components: Build, Packaging and Test
>    Affects Versions: 2.3S, 2.3, 2.3AS
>            Reporter: Joern Kottmann
>            Priority: Trivial
>
> Right now the build fails if uimaj is build with a maven version prior 2.2.0, but it
does not fail in other projects.
> If a maven version prior 2.2.0 is used the build should fail with the invalid version
error message in
> all projects, instead of:
> [INFO] Error configuring: org.apache.maven.plugins:maven-antrun-plugin. Reason: java.lang.NoSuchMethodError:
org.apache.tools.ant.util.FileUtils.close(Ljava/io/InputStream;)V

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message