uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-2971) Getters for boolean values in JCas wrappers don't follow common Java naming convention
Date Fri, 07 Jun 2013 20:50:21 GMT

    [ https://issues.apache.org/jira/browse/UIMA-2971?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13678421#comment-13678421
] 

Marshall Schor commented on UIMA-2971:
--------------------------------------

True.  I think we'd have to keep the old methods, for backwards compatibility.  Adding an
additional method would increase the size but probably by a very tiny amount.  
                
> Getters for boolean values in JCas wrappers don't follow common Java naming convention
> --------------------------------------------------------------------------------------
>
>                 Key: UIMA-2971
>                 URL: https://issues.apache.org/jira/browse/UIMA-2971
>             Project: UIMA
>          Issue Type: Bug
>          Components: Core Java Framework
>            Reporter: Richard Eckart de Castilho
>
> The getter generated for a boolean feature "XXX" in a JCas wrapper is called "getXXX".
It is a common Java convention, that getters for boolean values are called "isXXX".

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message