uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Eclipse UIMA tooling in 3.7.2 - works for me using DropIns, after installing EMF SDK
Date Tue, 02 Jul 2013 19:14:02 GMT
I just now tried:

  0) unzip a brand-new Eclipse 3.7.2

  1) copying the plugins for base UIMA to the dropins folder

  2) starting Eclipse - make a Java project, tried to make a new UIMA AE
descriptor - but the UIMA pick in the context menu wasn't there.

  3) Did an "install" of EMF SDK from the install-new-software page, restarted

  4) Now the UIMA pick was in the context menu - I created a new AE descriptor,
and it came up OK

  5) checked the error log - no error showing.

-Marshall

On 7/2/2013 12:44 PM, Peter Klügl wrote:
> Am 02.07.2013 17:45, schrieb Marshall Schor:
>> I tried as follows:
>>
>> 1) installed a new copy of Eclipse 3.7.2 (64 bit, windows)
>>
>> 2) ran the install-new-software, pointed to the site generated by running the
>> eclipse update site build
>>
>> (I don't know if drop-in works, because the install requires some prereqs like
>> EMF tools; I don't know if these get installed when you do the drop-in).
>>
>> 3) made a new project, and made a new analysis engine descriptor in that
>> project, which opened fine in the Component Descriptor Editor.
>
> I copied the plugin to the dropins folder (no installation using an update
> site) of an eclipse 3.7.2, with which the plugin should have worked. I will
> try to reproduce my steps when I find the time.
>
> Best,
>
> Peter
>
>> -Marshall
>>
>> On 7/2/2013 10:07 AM, Peter Klügl wrote:
>>> I did not check the update site when I reviewed the rc.
>>>
>>> However, I observed such problems when I tried to use the new runtime
>>> plugin in Eclipse 3.7.2. (a few days ago)
>>>
>>> Best,
>>>
>>> Peter
>>>
>>>
>>> On 02.07.2013 16:03, Richard Eckart de Castilho wrote:
>>>> I checked out the rc tag and built it: ok. (mvn clean install)
>>>>
>>>> I updated my local uimaj checkout, updated it to use the rc and built: ok.
>>>> (mvn clean install)
>>>>
>>>> I installed the resulting Eclipse plugins in my Eclipse (dropins folder)
>>>> and tried to open a type system in the component editor:
>>>> ClassNotFoundException: org.apache.uima.resource.metadata.ResourceMetaData.
>>>>
>>>> Can anybody confirm this?
>>>>
>>>> -- Richard
>>>>
>>>> Am 01.07.2013 um 17:06 schrieb Marshall Schor <msa@schor.com>:
>>>>
>>>>> On 7/1/2013 11:03 AM, Marshall Schor wrote:
>>>>>> On 7/1/2013 10:49 AM, Peter Klügl wrote:
>>>>>>> On 01.07.2013 16:44, Marshall Schor wrote:
>>>>>>>> On 7/1/2013 8:50 AM, Peter Klügl wrote:
>>>>>>>>> Will there be another rc or should we still test the
current one?
>>>>>>>> I may have missed something - I haven't seen any issues yet
needing
>>>>>>>> fixing in
>>>>>>>> these artifacts.  I've removed the "excess" projects from
the SVN tag,
>>>>>>>> to reduce
>>>>>>>> confusion (they were put there by the maven release plugin).
>>>>>>> Nevermind, I did not know whether this modification causes a
new
>>>>>>> vote/rc. If there is still need for one more, I will cast my
vote
>>>>>>> tomorrow after some reviewing.
>>>>>> There is so far just 1 +1 vote (mine).   Need 2 more :-)
>>>>> Richard may have voted +1, or may have just said +1 to my suggestion
to
>>>>> remove
>>>>> the extra projects in the tag - Richard can you clarify?
>>>>> Thanks.
>>>>> -Marshall
>>>>>
>
>


Mime
View raw message