uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandre Patry <alexandre.pa...@keatext.com>
Subject Re: [VOTE] Release Apache UIMA Ruta 2.2.0 RC3
Date Thu, 20 Mar 2014 14:22:38 GMT
- Compare soure.zip with svn - OK
- mvn clean install from source - OK
- Install plugin in eclipse - OK
- Run a test using new IMPORT features in eclipse - OK

[x] +1 OK to release


Alexandre

On 19/03/2014 09:53, Peter Klügl wrote:
> Hi,
>
> Am 19.03.2014 14:50, schrieb Alexandre Patry:
>> Hi Peter,
>>
>> I tried to compile RUTA yesterday, but the build failed at the eclipse
>> plugins. I once was able to compile everything, but I do not remember
>> the exact maven configuration. Is there some documentation that I
>> could look at?
>>
> mvn clean install on trunk should work just fine.
>
> What is the error message?
>
> Peter
>
>
>> Thanks,
>>
>> Alexandre
>>
>> On 19/03/2014 05:26, Peter Klügl wrote:
>>> Thanks Marshall!
>>>
>>> I will fix the RAT exclusions. I will take a look at the issuesFixed
>>> differences.
>>>
>>> ... so we need one more vote *looking around*
>>>
>>> Peter
>>>
>>> Am 18.03.2014 16:09, schrieb Marshall Schor:
>>>> compare source.zip with svn - OK
>>>>
>>>> good sig on source.zip
>>>>
>>>> build from source -OK (after clearing ruta* things from local repo)
>>>>
>>>> RAT excludes: has some redundancies I think (not a blocker):
>>>>       src/test/resource:
>>>>           org/apache/uima/ruta
>>>>               action/*.* and
>>>>               action/*ruta
>>>>
>>>>       duplicate src/test/resources/org/apache/uima/ruta/engine/*txt
>>>>
>>>> License / notice checked in base and in some Jars - OK
>>>>
>>>> issueFixed - shows (only) 64 issues, but Jira shows 67 issues.
>>>> This is due (I think) to 3 (missing) issues being marked "Done:",
>>>> "Implemented",
>>>> or "Cannot Reproduce" as their resolution status.  Not a blocker, I
>>>> think.
>>>>
>>>> installed plugins into Eclipse 4.3.2 , made new Ruta project - OK
>>>> (Note: doc lists explicit versions of Eclipse, doesn't include 4.3.x
>>>> (includes
>>>> 4.2...)
>>>>
>>>> Looked at the staging repo for maven - OK
>>>>
>>>> [x] +1 OK to release
>>>>
>>>> -Marshall
>>>>
>>


-- 
Alexandre Patry, Ph.D
Chercheur / Researcher
http://KeaText.com


Mime
View raw message