uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: [VOTE] Release Apache UIMA Ruta 2.2.0 RC6
Date Thu, 10 Apr 2014 15:41:31 GMT
Maybe we could do this once, and put the "repo" in our website.  We should ask
infra about this first though, I think, in case there's a better place.

-Marshall
On 4/10/2014 11:06 AM, Peter Klügl wrote:
> Am 10.04.2014 15:57, schrieb Marshall Schor:
>> On 4/10/2014 4:11 AM, Peter Klügl wrote:
>>> I'll try to reproduce it, but my maven knowledge is probably too limited
>>> that I will find the cause or solution.
>>>
>>> Independently of this issue, we should slowly find another solution than
>>> the external repository. It was supposed to be a temporary solution
>>> anyway. However, the only thing I can think of is to completely change
>>> the way the plugins are built, exchanging felix with tycho. That's quite
>>> some work for my limited time right now. Maybe there will be another
>>> volunteer?
>> Another way may be to have anyone who wants to build this create their own
>> mini-repo of eclipse artifacts from their installed Eclipse.  I found
>> instructions once on how to do this, and did it - and it worked.
>>
>> -Marshall
> Yes, that's how I started and it's probably a good fallback plan.
> Shouldn't be a problem for us, but maybe it's a bit cumbersome for
> others, for example, students that never heard of maven.
>
> We would need to do that also for the jenkins build.
>
> Peter
>
>
>>> Peter
>>>
>>> Am 09.04.2014 23:53, schrieb Marshall Schor:
>>>> I've discovered some strange issue with building Ruta from sources (but I
won't
>>>> call it a blocker).
>>>>
>>>> It happens when building with Maven version 3.2.1 (and probably any version
3.1
>>>> and above).  Maven version 3.0.5 can be made to work.
>>>>
>>>> I think it's something involving the
>>>> http://zoidberg.ukp.informatik.tu-darmstadt.de/artifactory/public-ext-osgi-releases-local
>>>> repository - it may have some updating needed to be done in order to work
with
>>>> maven 3.2.1.
>>>>
>>>> Here's how I get the failure:
>>>>
>>>> First, delete from your local .m2 repo the org/eclipse/* stuff. Then switch
to
>>>> maven 3.2.1 (I also have JAVA_HOME set to an IBM Java 7 - but I think that's
not
>>>> an issue).  If set up my .m2 settings.xml file to use a local Nexus Mirror
that
>>>> is proxying the zoidberg... site, that mirror fails to download the
>>>> org.eclipse.dltk.core artifacts.  In fact, looking at this in my local nexus
>>>> shows something odd:
>>>>
>>>> the "Browse Index" in my Nexus for this proxy shows:
>>>> top-level
>>>>    + com
>>>>    + eu
>>>>    - org
>>>>      - eclipse
>>>>         + compare
>>>>         + compare
>>>>         + core
>>>>         + debug
>>>>         - dltk
>>>>           + console
>>>>           + console
>>>>           + core
>>>>           + core
>>>>           + debug
>>>>           + debug
>>>>           + formatter
>>>>           + launching
>>>>           + testing
>>>>        ... etc
>>>>
>>>> Note the duplicate directory names.
>>>> The "first one" that fails is not finding the jar / pom for
>>>> org/eclipse/dltk/core/3.0.1
>>>>
>>>> If I expand the ..dltk/core, I see for both entries:
>>>>           - core
>>>>             - manipulation
>>>>               + 3.0.0
>>>>
>>>> So I think the index on this repo (which might be located at the top level)
is
>>>> corrupted.
>>>>
>>>> If I turn off the Nexus mirror, (comment out the stanza in my settings.xml
file)
>>>> and use maven version 3.2.1, it also fails.
>>>>
>>>> With my local Nexus mirror off, and switching back to Maven 3.0.5, the build
>>>> works - it finds the artifacts OK.
>>>> I'm guessing that Nexus and Maven (as of release 3.2.1 or so) both make use
of
>>>> the info in the .index directory, but Maven 3.0.5 maybe doesn't rely on it.
>>>>
>>>> I see the .index directory at
>>>> http://zoidberg.ukp.informatik.tu-darmstadt.de/artifactory/public-ext-osgi-releases-local
>>>> has a couple of files that have today's date - were they rebuilt today, and
did
>>>> something go wrong with that?
>>>>
>>>> -Marshall  
>>>>  
>>>>  
>>>>
>
>


Mime
View raw message