uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Burn Lewis <burnle...@gmail.com>
Subject Re: [VOTE] Release UIMA-AS 2.6.0 RC5
Date Tue, 15 Jul 2014 19:21:03 GMT
Also checked LICENSE & NOTICE in binary distribution and after the build
from source.

[ ] +1 Still approve the release


On Fri, Jul 11, 2014 at 10:53 AM, Burn Lewis <burnlewis@gmail.com> wrote:

> Checked source & binary signatures
> Built from source
> Built DUCC against that build
> Installed DUCC and ran multiple UIMA-AS jobs using an http application
> broker
>
> [ ] +1 Approve the release
>
>
> On Fri, Jul 11, 2014 at 9:05 AM, Jaroslaw Cwiklik <uimaee@gmail.com>
> wrote:
>
>> Built from source - OK
>> Spot checked signatures - OK
>> Spot checked LICENSE and NOTICE - OK
>> Checked UIMA-AS API formatting - OK
>> Installed Deployment Editor in eclipse - OK
>> Tested sending CASes to a service using HTTP and TCP - OK
>>
>> [ ] +1 Approve the release
>>
>> Jerry
>>
>>
>> On Thu, Jul 10, 2014 at 4:01 PM, Marshall Schor <msa@schor.com> wrote:
>>
>> > signatures OK
>> > compare source-release with SVN -OK
>> > eclipse plugin install - OK (in Eclipse 4.3.2)
>> > build from sources after clearing local repo of uima-as artifacts: OK
>> >
>> > run extended tests:  bumpy but ok eventually.   I was running from
>> Eclipse
>> > and
>> > my Eclipse doesn't quite do the right thing on building - it misses out
>> > generating some xmlbean things (but build from command line with mvn
>> > works).
>> >
>> > Also found a wrong version of Java compiler source / target in the poms,
>> > need to
>> > upgrade to parent-pom 10 (when that's released) and/or override in the
>> > meanwhile.  This doesn't seem to have affect the build, when built with
>> a
>> > Java 7
>> > JVM (which the Manifests indicate the binary build artifacts were built
>> > with) -
>> > the tests and extended tests both ran fine.  So I don't consider this a
>> > blocker.
>> >
>> > issues fixed - OK
>> >
>> > Spot check many licenses & notices in Jars in the binary release
>> > (especially the
>> > new ones), and one in the Maven Artifacts in the staging repo: OK.
>> >
>> > check main license / notice in source and bin - OK
>> >
>> > Readme says "tested with Sun Java 6 on Windows XP"  - probably needs
>> > updating?
>> > I think we mainly test with Java 7 and on Windows we use Windows 7 (or
>> 8),
>> > not
>> > XP...   I don't consider this a release blocker.
>> >
>> > Did the quickstart in the Readme - OK.
>> >
>> > [x] +1 OK to release.
>> >
>> > -Marshall Schor
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message