uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Burn Lewis <burnle...@gmail.com>
Subject Re: [VOTE] Release Apache UIMA Ruta 2.2.1 RC1
Date Thu, 18 Sep 2014 11:56:28 GMT
Marshall told me 3.4.2 but I should have realized that he's not that old!
So is the answer that 3.7.2 is not supported?

~Burn

On Thu, Sep 18, 2014 at 5:08 AM, Peter Klügl <pkluegl@uni-wuerzburg.de>
wrote:

> The <Require-Bundle> element misses some entries that have been taken
> care of the <Import-Packages> element. I think it should work just fine
> if all required bundles are listed.
>
> However, I remember that there was a reason to use the imports instead
> of the bundles, but I do not recall it right now.
>
> Best,
>
> Peter
>
> Am 18.09.2014 10:59, schrieb Peter Klügl:
> > It's the org.eclipse.core.runtime dependency of the CAS Editor plugin in
> > combination with the "Import-Package" element in the pom. The version
> > range is set to [3.3.0,4.0.0) and felix then includes the import for the
> > transitive dependency to org.eclipse.osgi, which exports the
> > org.osgi.framework package for a specific version. Thus, the version
> > range in the manifest.
> >
> > The ruta-ep-ide plugin has also a dependency to org.eclipse.core.runtime
> > (with even [3.3.0,5.0.0) as range), but there is no import of
> > org.osgi.framework in the manifest. I assume the reason for this is the
> > fact that the ruta plugin does not prevent the import of specific
> > packages and does not allow to import all others (<Import-Package>...
> > !org.eclipse.core.runtime,*...). When, I remove the content of the
> > Import-Package element, then the manifest looks fine, but the CAS Editor
> > does not find a uima class when started. But this problem should be
> > solvable.
> >
> > Does anyone remember why the imports have been specified this way?
> >
> > Best,
> >
> > Peter
> >
> >
> > Am 18.09.2014 10:26, schrieb Peter Klügl:
> >> Am 17.09.2014 23:31, schrieb Burn Lewis:
> >>> + Downloaded source zip & verified md5 checksum
> >>> + Built from source on Windows
> >>> + Verified md5 checksum on the binary build produced
> >>> + Started new Eclipse 3.7.2 (Indigo) on Windows
> >>> + Added the rc1 Ruta update site & the public Apache UIMA update site
> >>>
> >>> - Selected just the Ruta one (& checked "contact all...") and got:
> >>>
> >>> *  Software being installed: UIMA Ruta Workbench 2.2.1
> >>> (org.apache.uima.ruta.feature.feature.group 2.2.1)  Missing
> requirement:
> >>> Apache UIMA Eclipse: uimaj-ep-cas-editor 2.6.0
> (org.apache.uima.caseditor
> >>> 2.6.0) requires 'package org.osgi.framework [1.7.0,2.0.0)' but it
> could not
> >>> be found*
> >> Yes, the CAS Editor plugins specify an import of the package
> >> org.osgi.framework, but I do not know yet why felix has generated this
> >> entry. The ruta plugins do not have this requirement, but depend on
> >> these plugins. We should investigate this problem, but there is probably
> >> nothing I can do for the current UIMA Ruta release. I assume it can yet
> >> be resolved after the next uimaj release.
> >>
> >>
> >>> Got same error when selected both Ruta & UIMA Runtime.  I see others
> have
> >>> reported problems with osgi ... Marshall was successful with Eclipse
> 3.4.2
> >>> but I am already 4 releases back from the latest ....!
> >> Just for not confusing others that read this. It was Eclipse 4.3.2.
> >>
> >>
> >> Peter
> >>
> >>> ~Burn
> >>>
> >>> On Wed, Sep 17, 2014 at 3:58 AM, Peter Klügl <pkluegl@uni-wuerzburg.de
> >
> >>> wrote:
> >>>
> >>>> ... another reminder since it has been two weeks now since the vote
> >>>> started. Only one more vote is needed.
> >>>>
> >>>> Best,
> >>>>
> >>>> Peter
> >>>>
> >>>> Am 10.09.2014 22:57, schrieb Marshall Schor:
> >>>>> Hi, gentle prodding to get a 3rd PMC vote to permit releasing ...
> It's
> >>>> been a week.
> >>>>> -Marshall
> >>>>>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message