uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: UIMA-SDK » Apache UIMA Base: uimaj-core #724
Date Mon, 04 May 2015 21:53:19 GMT
See <https://builds.apache.org/job/UIMA-SDK/org.apache.uima$uimaj-core/724/changes>

Changes:

[schor] [UIMA-4377] don't allow moveToNext/Previous for an invalid iterator to make it become
valid.

[schor] [UIMA-4377] don't allow moveToNext/Previous for an invalid iterator to make it become
valid.

[schor] [UIMA-4377]

[schor] no Jira - clarify one javadoc comment

[schor] no Jira add trivial getTypeCode() method to have more transparent code for doing this,
and augment one comment

[schor] no Jira, update documentation - add refIterators

------------------------------------------
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Apache UIMA Base: uimaj-core 2.7.1-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ uimaj-core ---
[TASKS] Scanning folder 'F:\jenkins\jenkins-slave\workspace\UIMA-SDK\trunk\uimaj-core' for
files matching the pattern '**/*.java' - excludes: 
[TASKS] Found 904 files to scan for tasks
Found 65 open tasks.
[TASKS] Computing warning deltas based on reference build #722
[INFO] 
[INFO] --- maven-enforcer-plugin:1.3.1:enforce (enforce-versions) @ uimaj-core ---
[INFO] 
[INFO] --- build-helper-maven-plugin:1.8:parse-version (parse-project-version) @ uimaj-core
---
[INFO] 
[INFO] --- uima-build-helper-maven-plugin:7:parse-date-time (set buildYear and buildMonth)
@ uimaj-core ---
[INFO] 
[INFO] --- maven-resources-plugin:2.6:copy-resources (setVersions) @ uimaj-core ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 1 resource
[INFO] 
[INFO] --- build-helper-maven-plugin:1.8:add-source (addVersionSrc) @ uimaj-core ---
[INFO] Source directory: F:\jenkins\jenkins-slave\workspace\UIMA-SDK\trunk\uimaj-core\target\generated-sources\releaseVersion
added.
[INFO] 
[INFO] --- maven-remote-resources-plugin:1.5:process (default) @ uimaj-core ---
[INFO] 
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ uimaj-core ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 15 resources
[INFO] Copying 3 resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ uimaj-core ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 705 source files to F:\jenkins\jenkins-slave\workspace\UIMA-SDK\trunk\uimaj-core\target\classes
[INFO] -------------------------------------------------------------
[WARNING] COMPILATION WARNING : 
[INFO] -------------------------------------------------------------
[WARNING] /F:/jenkins/jenkins-slave/workspace/UIMA-SDK/trunk/uimaj-core/src/main/java/org/apache/uima/analysis_engine/impl/AnalysisEngineImplBase.java:
Some input files use or override a deprecated API.
[WARNING] /F:/jenkins/jenkins-slave/workspace/UIMA-SDK/trunk/uimaj-core/src/main/java/org/apache/uima/analysis_engine/impl/AnalysisEngineImplBase.java:
Recompile with -Xlint:deprecation for details.
[WARNING] /F:/jenkins/jenkins-slave/workspace/UIMA-SDK/trunk/uimaj-core/src/main/java/org/apache/uima/cas/impl/FSIntArrayIndex.java:
Some input files use unchecked or unsafe operations.
[WARNING] /F:/jenkins/jenkins-slave/workspace/UIMA-SDK/trunk/uimaj-core/src/main/java/org/apache/uima/cas/impl/FSIntArrayIndex.java:
Recompile with -Xlint:unchecked for details.
[INFO] 4 warnings 
[INFO] -------------------------------------------------------------
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR : 
[INFO] -------------------------------------------------------------
[ERROR] /F:/jenkins/jenkins-slave/workspace/UIMA-SDK/trunk/uimaj-core/src/main/java/org/apache/uima/cas/impl/FSIndexRepositoryImpl.java:[78,8]
org.apache.uima.cas.impl.FSIndexRepositoryImpl is not abstract and does not override abstract
method getIndexes() in org.apache.uima.cas.FSIndexRepository
[ERROR] /F:/jenkins/jenkins-slave/workspace/UIMA-SDK/trunk/uimaj-core/src/main/java/org/apache/uima/cas/impl/FSIndexRepositoryImpl.java:[1917,56]
getIndexes() in org.apache.uima.cas.impl.FSIndexRepositoryImpl cannot implement getIndexes()
in org.apache.uima.cas.FSIndexRepository
  return type java.util.Iterator<org.apache.uima.cas.FSIndex<? extends org.apache.uima.cas.FeatureStructure>>
is not compatible with java.util.Iterator<org.apache.uima.cas.FSIndex<org.apache.uima.cas.FeatureStructure>>
[INFO] 2 errors 
[INFO] -------------------------------------------------------------

Mime
View raw message