uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: [VOTE] Release Apache UIMA Ruta 2.3.0 RC3
Date Mon, 01 Jun 2015 13:32:00 GMT
I think this is OK, then.

-Marshall

On 5/31/2015 8:03 AM, Peter Kl├╝gl wrote:
> Hi,
>
> yes, we updated the antlr dependency last year for UIMA-3744 (problem with
> java 8), but I did not adapt the license file.
>
> Hmm, the difference of the license text could maybe be caused by the the
> version. I assume that you referring to
> http://www.antlr.org/license.html
>
> However, we we still use antlr 3 and there is a different license text for
> that version:
> http://www.antlr3.org/license.html
> (should be the text we use in ruta-ep-engine)
>
> Best,
>
> Peter
>
> PS: we should probably move to antlr 4, but I was always not really keen on
> all the work that could be caused by it...
>
> Am 29.05.2015 um 22:34 schrieb Marshall Schor:
>> Checking the release - all looks good up to checking some licenses.
>>
>> When I looked at ruta-ep-engine (from the staging repo) -
>> that jar includes antlr-runtime-3.5.2 jar (released March 2014).  The license
>> file for ruta-ep-engine mentions this, but seems to use an older license
>> version.  For instance, it says copyright 2010.  The current license on the
>> antlr website says copyright 2012, and has two names, not one for the copyright
>> holders.
>>
>> Did this artifact get updated in the ep-engine, but the license text not get
>> updated?
>>
>> -Marshall
>>
>
>


Mime
View raw message