uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eddie Epstein <eaepst...@gmail.com>
Subject Re: [VOTE] Release UIMA-AS 2.8.1 RC2
Date Mon, 15 Feb 2016 23:37:23 GMT
-1 Not OK to release, because CAS priming fails when the location of the
file containing warmup CASes is specified to be in the classpath. Details
below.

- Downloaded the binary tarball, unpacked, set UIMA_HOME and updated PATH
and ran adjustExamplePaths.sh.

 - startBroker.sh worked no problem.

 - created a zip file with CASes to test the new feature CAS priming by:
   a. capturing 8 XMI test CASes by enabling "CAS Logging" for delegate
RoomNumber
      (see
file://$UIMA_HOME/docs/d/uima_async_scaleout.html#ugr.async.mt.tuning.settings)
   b. deploying Deploy_MeetingDetectorTAE_3MeetingAnnotators.xml with
deployAsyncService.sh,
   c. running 8 sample inputs with:  runRemoteAsyncAE.sh
tcp://localhost:61616 MeetingDetectorTaeQueue -c
$UIMA_HOME/examples/descriptors/collection_reader/FileSystemCollectionReader.xml
   d. and then zipping the 8 .xmi files into a file: prime.zip

 - redeployed the MeetingDetectorTAE with priming and JMX enabled:
     UIMA_JVM_OPTS="-DWarmUpDataPath=$UIMA_HOME/TESTDIR/Prime/prime.zip
-Dcom.sun.management.jmxremote.port=12345
-Dcom.sun.management.jmxremote.authenticate=false
-Dcom.sun.management.jmxremote.ssl=false" deployAsyncService.sh
../examples/deploy/as/Deploy_MeetingDetectorTAE.xml

 - the service logfile indicated warmup happening:
06:21:46.156 - 26:
org.apache.uima.aae.controller.BaseAnalysisEngineController.runWarmup:
INFO: Service: Meeting Detector TAE Thread: 26 Warming Up The Pipeline ...
06:21:46.364 - 26:
org.apache.uima.aae.controller.BaseAnalysisEngineController.runWarmup:
INFO: Service: Meeting Detector TAE Thread: 26 WarmUp Has Finished
Successfully - Processed: 8 CASes - Time Spent Warming Up: 0 secs- Ready
For Processing

 - used jconsole to confirm that the service really did process 8 CASes.

 - converted the zipfile with 8 XMI format CASes into a zipfile with binary
CAS form 6 CASes (will put conversion program into SVM for furture release)

 - confirmed that warmup worked OK with binary CAS input

 - put prime.zip into a jar file, added jar to classpath, and specified
file location as "Prime/prime"

 - service deployment failed with the stack below. I think the problem is
that priming code appears to be using the standard UIMA import by name
utilities that expect files to end with ".xml" and not ".zip".

org.apache.uima.util.InvalidXMLException: An import could not be resolved.
No file with name "Prime/prime.zip" was found in the class path or data
path. (Descriptor: <unknown>)
    at
org.apache.uima.resource.metadata.impl.Import_impl.findAbsoluteUrl(Import_impl.java:115)
    at
org.apache.uima.aae.WarmUpDataProvider.resolveToAbsolutePath(WarmUpDataProvider.java:97)
    at
org.apache.uima.aae.WarmUpDataProvider.<init>(WarmUpDataProvider.java:83)
    at
org.apache.uima.aae.controller.BaseAnalysisEngineController.runWarmup(BaseAnalysisEngineController.java:2971)
    at
org.apache.uima.aae.controller.BaseAnalysisEngineController.warmUp(BaseAnalysisEngineController.java:2957)
    at
org.apache.uima.aae.controller.PrimitiveAnalysisEngineController_impl.initializeAnalysisEngine(PrimitiveAnalysisEngineController_impl.java:333)
    at
org.apache.uima.aae.UimaAsThreadFactory$1.run(UimaAsThreadFactory.java:119)
    at java.lang.Thread.run(Thread.java:798)




On Thu, Jan 21, 2016 at 1:49 PM, Jaroslaw Cwiklik <uimaee@gmail.com> wrote:

> Hi,
>
> the UIMA-AS 2.8.1 release candidate 2 is ready for voting.
>
> This version contains the following fixes for problems found in RC1:
>
> - Modified README to simplify description of warm up
> - Updated UIMA-AS documentation to include description of warm up
> - Fixed warm up code to resolve zip file by name in addition to by location
> - Fixed startBroker script.
> - Fixed wrong LICENSE and NOTICE files in binary and source releases
>
>
> The list of changes in Jira:
>
> https://issues.apache.org/jira/issues/?jql=fixVersion%20%3D%202.8.1AS%20AND%20project%20%3D%20UIMA
>
> The source and binary zip/tars and the Eclipse update site are staged to
> http://people.apache.org/~cwiklik/releases/uima-as/2.8.1/RC2/
>
> The Maven artifacts are here:
> https://repository.apache.org/content/repositories/orgapacheuima-1082
>
> The SVN tags are here:
> http://svn.apache.org/repos/asf/uima/uima-as/tags/uima-as-2.8.1/
>
> and for the Eclipse Update Site:
>
> http://people.apache.org/~cwiklik/releases/uima-as/2.8.1/RC2/eclipse-update-site/uima-as/
>
> See http://uima.apache.org/testing-builds.html for suggestions on how to
> test
> release candidates.
>
> Please vote on release:
>
> [ ] +1 OK to release
> [ ] 0   Don't care
> [ ] -1 Not OK to release, because ...
>
> Thanks.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message