uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: [VOTE] Release UIMA-AS 2.8.1 RC3
Date Sun, 17 Apr 2016 22:20:05 GMT
Hi,

I'm starting to have a look at this. 

I observed that during the "build-from-sources" for uimaj-as-activemq, 169 files
were downloaded from maven (many were .poms, but many were Jars).  Are all of
these needed when doing the uimaj-as-activemq build?

Examples:
  jackson-annotations, core, databind, at 2.6.3 level
  guava 12.0
  netty 3.7.0
  websocket-api 1.0
  activemq-all, amqp, broker, console, http, jaas, jms-pool, kahadb-store,
leveldb-store, log4j-appender, mqtt, openwire-legacy, partition, pool,
runtime-config, shiro, spring, stomp, web,    5.13.2
  genesis-default-flava, java5-flava 2.1
  qpid/proton-m
  shiro/shiro-core, root, spring, web 1.2.4
  xbean-spring 3.18
  zookeeper 3.4.6
  jetty-all, -continuation,-http, -io, -security, -server, -servlet, -util,
websocket-api, websocket-client, websocket-common, websocket-server, 
websocket-servlet  9.2.13
  fusesource/hawtdispatch -scala, -transport, 1.22
  and a whole lot more....

This seems like a surprising number of dependencies for the uimaj-as-activemq
build.  What am I missing?

-Marshall
 

Mime
View raw message