uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marshall Schor (JIRA)" <...@uima.apache.org>
Subject [jira] [Commented] (UIMA-4988) UIMA plugins fail to install on Eclipse NEON
Date Thu, 14 Jul 2016 02:35:20 GMT

    [ https://issues.apache.org/jira/browse/UIMA-4988?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15376207#comment-15376207
] 

Marshall Schor commented on UIMA-4988:
--------------------------------------

The first error was caused by a strange configuration in my build machine.  The 2nd and 3rd
ones probably were due my getting impatient at the slowness of install, cancelling it, and
then restarting it after unchecking the box to "contact all update sites during install to
find required software".

That I fixed by rechecking the box, and waiting a very long time - eventually it did find
things.  But the first error (class not found running JCasGen from button on the Configuration
Editor) was caused by a bad build of the uimaj-ep-runtime plugin. This plugin has embedded
Jars from the UIMA runtime artifacts, including uimaj-tools (where the JCasGen code lives).
 The plugin had the correct Jar embedded, but the Manifest Entry (created by the maven Bundle
plugin inserted a wrong version in the Bundle-classpath value.  When I looked in my local
.m2 repository, there were multiple Jars in the path under the -2.8.2-SNAPSHOT spot - some
had the suffix 2.8.2-SNAPSHOT, others had the suffix 20160504.193039-25  which looks like
what Eclipse build of plugins uses for suffexes.  I don't know how those got into the .m2
repository - I'm guessing some action I took in Eclipse caused these to get built by Eclipse.

Removing the .m2 entry and rebuilding (with maven) the affected plugin fixed that issue.

> UIMA plugins fail to install on Eclipse NEON
> --------------------------------------------
>
>                 Key: UIMA-4988
>                 URL: https://issues.apache.org/jira/browse/UIMA-4988
>             Project: UIMA
>          Issue Type: Bug
>          Components: Eclipse plugins
>    Affects Versions: 2.8.1AS, 2.8.1SDK
>         Environment: Mac OS X
>            Reporter: James Zhu
>            Assignee: Marshall Schor
>              Labels: eclipse, features, plugin
>             Fix For: 2.8.1AS, 2.8.1SDK
>
>
> The new Eclipse version "NEON" came out. I run into problem when trying to install the
Eclipse plugins for UIMA and UIMA AS. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message