uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Eckart de Castilho <...@apache.org>
Subject Re: [jira] [Commented] (UIMA-2971) Getters for boolean values in JCas wrappers don't follow common Java naming convention
Date Thu, 08 Sep 2016 06:26:20 GMT
Better add your votes directly to the Jira issues.
There is actually a "vote" button there in each issue
under the section "People".

	https://issues.apache.org/jira/browse/UIMA-2971

Cheers,

-- Richard

> On 06.09.2016, at 12:48, Johannes Darms <johannes.darms@scai.fraunhofer.de> wrote:
> 
> +1 for changing from getXXX to isXXX
> 
> ----- Original Message -----
> From: "Marshall Schor (JIRA)" <dev@uima.apache.org>
> To: dev@uima.apache.org
> Sent: Monday, September 5, 2016 5:29:20 PM
> Subject: [jira] [Commented] (UIMA-2971) Getters for boolean values in JCas wrappers don't
follow common Java naming convention
> 
> [ https://issues.apache.org/jira/browse/UIMA-2971?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15465244#comment-15465244
] 
> 
> Marshall Schor commented on UIMA-2971:
> --------------------------------------
> 
> one other backwards compatible issue with making this change arises when and if the user
(who can customize the JCas code) might have written the isXXX style methods themselves, and
could have had it mean whatever they want.


Mime
View raw message