uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Eckart de Castilho (JIRA)" <...@uima.apache.org>
Subject [jira] [Updated] (UIMA-107) CPE GUI and CDE do not distinguish empty array from null
Date Fri, 09 Sep 2016 17:49:22 GMT

     [ https://issues.apache.org/jira/browse/UIMA-107?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard Eckart de Castilho updated UIMA-107:
--------------------------------------------
    Labels: Stale  (was: )

This issue is marked as "stale" due to inactivity for 5 years or longer. If no further activity
is detected on this issue, it is scheduled be closed as 'unresolved' in 3 months time from
now (Dec 2016).

> CPE GUI and CDE do not distinguish empty array from null
> --------------------------------------------------------
>
>                 Key: UIMA-107
>                 URL: https://issues.apache.org/jira/browse/UIMA-107
>             Project: UIMA
>          Issue Type: Improvement
>          Components: Eclipse plugins, Tools
>            Reporter: Adam Lally
>            Priority: Minor
>              Labels: Stale
>
> If editing a component descriptor by hand, a multi-valued parameter can either be set
to an empty array or to null.  However, the CDE and the CPE GUI both present a list widget
for these parameters, which does not provide any way to distinguish between the two.
> An empty array is specified in the descriptor by:
> <nameValuePair>
>   <name>paramName</name>
>   <value>
>     <array></array>
>   </value>
> </nameValuePair>
> Whereas a null is indicated by not specifying including a <nameValuePair> element
for the parameter at all.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message